No compass installed and getting Bad Compass Health message

I did not know where to post this Copter 3.2.1 or here since it is a helicopter?
Thanks in advance for any help.
APM 3.1 board, Ver 3.2.1 firmware, Helicopter setup, 450 Pro heli, Tarot FBL head.
This setup was working well for a few weeks while in the process of trying to tune the heli. Problem started for no reason I know of, I am getting a BAD COMPASS HEALTH message when trying to arm, thing is I have no compass hooked up, never did have? In mission planner mandatory hardware, compass, I have no boxes checked, nothing to indicate I have a compass installed?
I have read a lot of topics pertaining to bad compass health but these are people with a compass hooked up, I have none?
Any ideas to why I have this problem or is there a know fix for this?

Some but not all APM versions had a compass inside on the main flight controller PCB. You can go into the advanced parameters in mission planner and turn it off if you like. You will see a parameter something like compass_use_1. Just set it to 0 and it will disable that compass. If you see a parameter labeled:
Compass_dev_id= and there is a number there it means it found a compass.

Thanks Mike
My APM 3.1 ver 3.2.1 in advanced parameters had a compass setting for each X Y, and Z offset (seemed like random numbers) so I set them all to zero, also there is a compass offset (mine was -180 , I set to None? Saved, Reboot still had same problem? I turned off pre arm check and now it is arming like it should? I don’t know why but it is working?

It is working because you just “turned off the alarm bell” so it would not ring in your ear. You have not solved the problem. The compass x,y,z offsets are not random numbers. They are the calibration numbers and the compass will not work right without them.