Servers by jDrones

Nimbus Tricopter VTOL

Hi Greg: went out this morning again started out in Q_Stab then tried Q_Hover i did not notice any difference i had the throttle in the center switched to Q_Hover but i still had to control it just like it was still in Q_Stab mode? My wife took 2 short Video’s on the first take off and one of it landing but i haven’t figured out how to put it on here i also tried my bin file i guess it didn’t get thru either so ill try again oh you mentioned a host i don’t know what that is. Thanks B.K

Butch,

You can’t upload the .BIN file (or a video file) directly to a forum post because it is too large. You need to host it somewhere and then post a hyperlink.

The QHOVER mode adds in the BARO sensor which control altitude. You will still need the right stick control and left stick yaw but if you leave the throttle to mid position it should stay near the same height. The QHOVER mode also desensitizes the throttle setting so if you want to go up or down, you need to add more than normal throttle offset.

Once this seems to work, then try QLOITER mode. This adds in the GPS control to your BARO and should allow for some hands-off hovering. If there is a breeze, point the nose into it. The weathervane feature, if enabled, will do this for you automatically. The throttle is also desensitized in this mode. Remember to do this a bit higher up so you can switch back to QSTABILIZE, if needed.

Cheers!

Greg: Ok Thank You I’ll goggle to find a host.B.K

https://youtu.be/1zxvvuFTweQ https://youtu.be/r-pYZrhU66U

Boy, that’s a colorful finish! Very nice! It looks good to me. Why were the tailerons up? Like a bird showing off its feathers? :slight_smile:

Hi Greg: thank you, i was going to ask you about the V-Tail flaps at first,when after i did all the calibrations and in manual mode everything is good and when i go to Q_Stab the motors go up and so does the V_Tail flaps and everything stays that way until i go to FBWA mode then the motors go to 75 deg i’m guessing because it has to go forward for air speed to shut off the rear motor and the front motors will then drop to 90 deg and the ail and Tail flaps will work like in manual or FBWA mode and in all honesty i just thought thats the way they work,so now that you said that how do i attempt to fix or correct it?i have been trying to find host to put a log on here but it seems i’m not that tech savvy, well looks like a cold front coming in with some wind and rain so i’ll keep hunting. Thanks B.K

Something is not set up correctly here. Going from QSTABILIZE to FBWA should not change the v-tail. Also, your motors should point straight out in FBWA mode. You’ll need to adjust the tilt-rotor SERVOx_MIN or MAX settings to make these right.

I would level the plane, connect using Mission Planner and verify it looks level in the HUD. If not, re-calibrate your ACCs. You are probably fine here as it hovered nicely. Next go to Manual mode. Make sure that the motors point out and the control surfaces for aileron and v-tail (elevator and rudder) all seem correct using the transmitter. If they are not neutral at stick center then adjust the SERVOx_TRIM setting for each surface needed.

Next, go to FBWA mode and this time check the control surfaces buy moving the plane up/down and rolling left/right. You won’t see any rudder offset when not flying, only aileron and elevator. Perhaps something is reversed here.

Good luck!

https://youtu.be/38-MJU7wSds HI Greg: Everything looks good in Stab/manual mode,switched to Q Stab mode,Qhover,and Qloiter everything looks good on the wing/Ail and the V-Tail flaps go up none of the flaps move using the sticks on the Tx except the movement of the motors when using the Rud ,when using the Ail/elev stick the motor movement is minor and i can tell the motors speed up or slow down. when going into FBWA mode with no throttle the motors point straight ahead and i have full control of the ail,and V-tail using the Tx sticks,and if i start the motors and get into FBWA mode the motors go to about 75Deg and all 3 motors keep running maybe this vid will show that,i tried rolling and pitching the plane by hand while sitting and i got slight movement of the Ail only in FBWA mode,Both the Ail and Vtail flaps move when in Q-Stab mode when i roll and pitch the plane by hand, well maybe i should put it in FBWA mode and adjust the vtail flaps so they are in Neutral? IDK but i thought that you mentioned that the plane had to go forward and the air speed then would shut the rear motor off and the motors would down/forward?Oh saw on the news youguys might of gotten some snow and really could air.Thanks B.K

Butch,

Is it possible that you did not center your v-tail servos before mounting the arm? If you look at your v-tail servo arm, they should be pointing straight back when the stick is neutral and the plane is level.

Check to see that SERVO2_TRIM and SERVO4_TRIM are between 1450 and 1550. If so then re-position your servo arm to near straight back and then fine tune it with the trim settings. The fine tuning can be done with the v-tail mounted.

Yeah, we have snow on the ground since Friday. I need to keep warm until April-May now. :cold_face:

Morning Greg: I did that in Manual Mode with Ail,Elev,Thro,Rud, then switch to Q-Stab and both Tail flaps go up. right now in MP servo 2 is function 80 max=800,min=2000,rev=0,trim=1500 Servo 4 is Fun= 79,max=2000,min=800,rev=0,trim=1500. Now should i Put it in Q-Stab and do the V-tail meaning re adjust=take servo arms off and level them as close to center and then use trim to get flaps centered=flat/level with tail surfaces ?Thanks B.K

Butch,

I would forget about Manual Mode as you will never use it on a VTOL. Also, the Nimbus does not have flaps so I will assume that you mean ailerons.

  • In FBWA mode, level the plane
  • Calibrate the single axis level acc in Mission Planner, if needed
  • Calibrate the radio in Mission Planner, if needed
  • Adjust all control surfaces for neutral when the sticks are neutral.
  • Verify correct control surface direction using the transmitter sticks for aileron, elevator, and rudder.
  • Verify correct compensation for aileron when moving the plane on the roll axis
  • Verify correct compensation for elevator when moving the plane on the pitch axis

Good luck!

Hi Greg:Morning, i hooked it up to MP, Plugged in the battery went to mp and deleted the manual mode,then i removed the Ail servo rods and V-tail servo horns,then leveled the plane ,i calibrated the ACC and the Tx in MP,i put in FBWA mode and adjusted and put the Ail and V-Tail surfaces in neutral and tightened them down and made adjustments to the trim values ,then unplugged the Batt and un plugged MP and turned off the Tx. then fired it up again in MP and Batt Connected in Q_Stab mode then QHov then QLoiter (No Change the VTail surfaces Both still go UP nothing moves but the tilt motors when using the Rud and Ail/Elev sticks then in FBWA mode all Ail and Vtail surfaces return to level and operate like their supposed to and the rear motor keeps running and the front motors go down to about 75 deg like in the video Not straight forward???OH how does one verify correct compensation how much they are supposed to Move in both directions for the Ail,Elev ans V Tail ? i had downloaded another video and attached it to this message last nite but we have no internet here in this RV Park we use our phones hot spot and i guess it got interrupted so i’m trying it again https://youtu.be/eYr3c2yh5_0 , Cheers and Thanks i’m still looking for a host to download a data flash log so maybe you could take a look cause i gotta have something wrong some where again Thanks.B.K

This is not normal so don’t fly forward until this is fixed. Just imagine switching back from FBWA mode to QSTABILIZE and your v-tail goes up while the plane is still moving forward. I suspect a configuration issue here. You can post the .param file directly to the forum without hosting it.

Can’t see the video but it should be out 90 degrees. Use the SERVOx_MAX or MIN settings to adjust it.

It’s all in the Wiki so you should read it. V-Tail Servo Function & Reversal

Good luck!

Nim Vtol.param (20.9 KB)

Butch,

I compared param files and saw one obvious difference. My right v-tail (SERVO2_REVERSED) is set to 1 and yours is set to 0. Also, you still have your ARMING_CHECK set to 0. Even for hover testing, you should change ARMING_CHECK to 1.

On all the other setups, where the SERVO2_FUNCTION is set to 80, the SERVO2_REVERSED is set to 1. My guess is that you have a double reversal between the radio setup and the APM setup. This is likely caused when using SERVO2_FUNCTION as 80 instead of 79. Either way will work, but one, the original Nimbus conversion setup, doesn’t follow the Wiki setup.

I would change SERVO2_REVERSED to 1 and then swap your SERVO2_MAX and SERVO2_MIN settings so that SERVO2_MAX = 2000 and SERVO2_MIN = 800.

These are my Horus/Taranis mixes for the Nimbus VTOL. All inputs are set to +100%. The key setting here is the elevator and aileron reversals (-100%). Ignore the offsets and expos.

HorusMixes

Hi Greg: Thank You I appreciate all your help and guidance, I made the change in MP with servo 2 fun 80 swapped max and min and reversed to 1 and i also changed the Tx ail and elev to -100 no offsets and i’ll Test it on the Plane after our visitors leave i had to put away my tools and the Plane not much room in this Park model ,Here’s what i can’t wrap my head around. if i have it in Q_Stab MODE and adjust the params and it seems Qhov and Qloit is the same thing but when i go to FBWA MODE and adjust the Params why doesn’t the FC remember these setting for these different Modes? anyway can’t wait to see if this helps,Thankyou B.K

Greg: servo 4 fun is 79 ,Max=2000 ,min=800 ,rev=0 , trim=1500, B.K

Butch,

You want your setup like this. The actual numbers for min, max, and trim can vary but the main thing is that the Function 80 servo is reversed and Max is higher than Min.

SERVO2_FUNCTION,80
SERVO2_MAX,2000
SERVO2_MIN,800
SERVO2_REVERSED,1
SERVO2_TRIM,1500

SERVO4_FUNCTION,79
SERVO4_MAX,2000
SERVO4_MIN,800
SERVO4_REVERSED,0
SERVO4_TRIM,1500

Good Day Greg: hope your staying warm,Thats how i have the settings now and i changed my Tx settings and i just finished it, i started it up in Q-Stab both motors straight up and the left ail up and the right down about 15 deg. V-Tail surfaces flat /even, Q-Hov, and Q_loit when using the Rud stick if i move stick left the left motor moves rearward the right motor moves forward V-Tail doesn’t move when i use the ail stick the motors sped up and slow down slightly can’t tell on which does what, when i use elev stick if pull back the motors speed up and when i put stick forward the motors slow way down this is all in the Q modes.
Change to FBWA= ail’s flat/even V-Tail flat and even But the rear motor’s continue to run and they drop forward to 35 deg still, When i move Ail stick left the left ail goes up the right one goes down the V-Tail =both go left when moving the ail stick right the right ail goes up the left ail goes down and on vtail both go Right. When using elev stick when i pull back on the elev stick the ail don’t move and on the V-Tail the left go left the righ go right= in my lingo (both Down) and when i fush forwad the vtai l left goes right left one moves left or both up and when using the rud stick i push stick to the left the left goes left the right goes left or (left down right up) and if i move stick right both go right or (left up right down). so i guess the only the only malfuction is when going to FBWA why isn’t the rear motor stopping and the front motors moving straight ahead and IDK are my surfaces correctly going the right way their supposed too? Thanks Looks Like WE (YOU) are making headway Thank You B.K

You should not be testing while armed. Disarm, then test.

Again, disarm, then test. The Q_M_SPIN_ARM parameter adjusts how fast the motors spin when armed. I prefer them to be off but some like them spinning for safety reasons.

Your settings are below. I would refer to the Configuring Arming section of the Wiki to better understand what is going on. As mentioned previously, you should change ARMING_CHECK to 1.

ARMING_CHECK,0
ARMING_REQUIRE,1
ARMING_RUDDER,2

Servers by jDrones