Servers by jDrones

Nimbus 1800 vtol


(Dick Ou) #1

I have nimbus 1800 ,test fly today,take off easy and stable hover, but I had yaw problem and FBWA problem, right rudder yaw over shot and left rudder yaw sluggish,
after transition to FBWA, plane unstable. BIN log attached, anyone can analyse my log file and give me your comments, thank a lot in advance.

logfile
[https://drive.google.com/drive/folders/0B7ZMiA0wxbnDcVcwSEpKa05lSEk]
(https://drive.google.com/drive/folders/0B7ZMiA0wxbnDcVcwSEpKa05lSEk)

Nimbus 1800 Y3 VTOL

Tail servo modification


(Andras Schaffer) #2

Hi Dick,
Are you using Kris Shyi’s custom firmware or the official Ardupilot one ?


(Dick Ou) #3

I am using official v3.82


(Andras Schaffer) #4

First check, on the ground (disarmed motors, but enabled safety) if you switch from qstabilize to fbwa the motors are tilting precisely 90 degree ? (Qstabiize, straight up, fbwa- stright forward…?)
If yes, the next question, are thew move together with the same speed ?
(ARSPD_FBW_MIN 11 is way to low, it needs at least 16m/s, with 4kg the stall speed is around 15m/s)

What props and motors are you using ?


(Dick Ou) #5

@Eosbandi, thank you for your help, my setup as following, exactly same as Kris and I used his parameter too, don’t know why my performance not as well as his.

Moter 1: front right sunnysky X4112 485KV with 14x7 prop. CW
Motor 2 front left sunnysky x4112 485kv with 14x7 prop. CCW
Motor 4. rear sunnysky 4112 400kv with 16x55 multirotor prop. CCW

My two tilt servo are Futuba 9255, 0.15sec/60 degree, at 4.8V, tilt down and up look OK. How do you think about servo speed? too low?

Arspd_fbw_min=11 too low, agree will change it and try.

Thank again

dick


(Andras Schaffer) #6

I still suspect the servos. The two identical servos should travel the same, but your setting shows a difference (altough not big, but it is one point). One has a 930ms between min and max, the other has 895ms. It also seems to me that your Yaw control is reversed…
Be carefull, since control directions must be ok in Q mode and in plane mode as well…


(Josh Mason) #7

Hi all, trying to build the VTOL Nimbus and wondering if anyone has a working param file I can look at/compare?


(Dick Ou) #8

@Josh_Mason

parameter for your compare
20170912.param (16.2 KB)


(Graham D) #9

Has anyone done an autotune on the Nimbus?


(Xavi Balaguer Zafra) #10

Hi Dick,

I’m very interested on buying a Nimbus 1800. Could you please send me some fotos from few angles? is just to make a 3D cad view. My mail is xbalaguer@hemav.com. After that i could send you back the result if you want

Thank you!


(Josh Mason) #11

Hoepfully someone is still reading this post. I have an issue where in plane mode all control surfaces move the correct way however in QSTAB or any other Q mode the forward and reverse movemnets are backwards. In other words, pulling back on the left stick produces forward movement and pushing forward moves the plane backwards. Would really appreciate any ideas you guys might have as I’ve been working on this forever trying to figure out what’s happening.


(Josh Mason) #12

Hi, would appreciate your help if possible. Per my new post below in plane mode all control surfaces move as expected but in Q modes the forward and reverse stick is backwards. Can’t figure out how to get it switched.


(Greg Covey) #13

Hi Josh,

The quad movements need to be set up first. This can be done using the Radio Calibration section in Mission Planner along with the reversing capability of your transmitter. You need to set the RCx_REVERSED parameters first. In Mission Planner, there is an easy checkbox for this on the Radio Calibration screen. A good page to read is the Migration from Plane 3.7 to 3.8 section.

Next, use the V-Tail Plane Setup in Plane to get the SERVOn_REVERSED settings correct.

Good luck!


(Josh Mason) #14

Thanks so much Greg. I’ll take a look at what you’ve suggested. I’m at the head against wall stage! Haha