Next FBWA or RTL

I’m normally a bright guy but I seem to be really struggling with the Pixhawk.
I am now to the very end of the process, that is checking out the FBWA and RTL modes on the ground. With my APM, when I switch to those modes and tilt the plane the FC adjusts the flight surfaces to correct the for changes in flight attitude.
Although the telem. indicates the FC is reading the command to go into FBWA or RTL, there is no servo response. Manual works fine.
Any help appreciated.

Is the Pixhawk armed or disarmed?

It is armed.
I sort of solved my problem and things are working now. I say sort of, because it is what we, in the satellite business, call cause unknown. The worst outcome to a failure is a cause unknown as you will not really know if you fixed it or not. :unamused:
What I did… Long ago, on my APM journey, I had a similar “unsolvable” problem. No matter how many times I erased and reset/re-loaded FW, I couldn’t get the APM to work correctly. In desparation, I loaded a different platform, in my case, a helicopter. Then I re-loaded the plane FW. What do you know, all worked. Don’t ask me why, I haven’t a clue but if someone else is stuck, try this trick. It has worked for me twice.

I will call this “solved” even though the cause is unknown and the fix is mysterious. :open_mouth: