Servers by jDrones

Newbie struggling with Ardupilot setup

I’m new to Ardupilot, and have just installed 4.0.0 in a Pixhawk 2.4.8 in my 550 Hexcopter. I’ve had several years’ experience with iNav and Betaflight in Omnibus and SPRacing boards, but I’m struggling to get my head around Ardupilot setup in Mission Planner. My transmitter is Taranis, and my receiver is FrSky R-XSR.

I’ve got a battery monitor, safety switch, and GPS/compass connected, and they all seem to be working fine in the Mission Planner Flight Data screen. But I haven’t yet been able to arm the hex to test the motors: First I got the ‘RCxx trim less than minimum’ error message, and fixed that by editing all the RCxx parameters that were showing 874 to the correct value of 1500. Then there was the same message for RC8, which shows maximum 1500 and minimum 1499, so I set trim for that to 1500 and got rid of its error message.

Then I got a message Prearm: CHECK FS_THR_VALUE, and tried to fix it by going into the MP Initial Setup > Failsafe screen and changing the FS Pwm value. The Radio Failsafe section of the copter documentations says the FS Pwm value should be 10PWM higher than the value when the throttle stick is fully down with the transmitter off, and 10PWM lower than the value when the throttle stick is fully down with the transmitter on. But MP shows my minimum throttle is 984 with the transmitter on or off, though it goes down to 982 when I activate the throttle-kill switch on my transmitter. So what value should my FS Pwm be, please?

PS I’ve been able to run the motors by going into the parameters list and disabling the throttle failsafe, but I’d like it to be working.

Have you done the radio calibration? Typically the lower limit is 1100 and upper is 1900. You can adjust those in your radio to hit those marks

Thanks Dave, I’ve done the radio calibration. I’ve just checked my Taranis settings, and my throttle is set at 100% whereas all other controls are set at 80% – and they’re showing about 1100 to 1900 in MP. I’ll reduce my throttle to 80% and then go through the calibration again.

You should NOT be using a throttle kill switch.

All of my radios run sub-1000 and over 2000.

DUMP THE KILL SWITCH. Put all of your end points and sub trims BACK TO STOCK. Make sure the stick trims are centered. Recalibrate the sticks/pots using the radio internal calibration. THEN recalibrate the radio using Mission Planner.

My failsafe is usually set FS_THR_VALUE,973.
I also find I sometimes have to mess with it a bit to get the number that makes it happy. But in general its around 10 points below the throttle min value.

My throttle stick runs 982 to 2006. I set the FS to 950.

OK, I’ll reset all my Taranis ranges to 100% instead of 80%, and recalibrate. Oldgazer, your FS setting of 950 meets the requirement to be at least 10PWM less than your minimum of 982, but what’s still confusing me is the other requirement for it to be 10PWM more than the Tx-off value – at the moment MP doesn’t show any change in my throttle value when I switch the Tx off. Dohhh, I’ve just realised that’s because my Rx failsafe probably sets the throttle to zero on loss of signal, because that’s how it was when I bound it :frowning:

For the moment I’ve disabled FS_THR in the parameters, so I can test the motors, and all is well. I’ve got to have a long think about this whole failsafe thing.

This is the requirement for FS_Thr.
If you think about it it really is saying the same thing. 10 points higher then the lowest value with your stick down and TX off or 10 points lower with the stick down and power on.
Easiest way to do it is set the sticks to the lowest point and then take at least 10 points off that value.
Try it and then adjust if needed

From the manual
At least 10 PWM higher than your Channel 3’s PWM value when the throttle stick is fully down and the transmitter is off - At least 10 PWM lower than your channel 3’s PWM value when the throttle stick is fully down and the transmitter is on - Above 910 PWM

Yes, that’s what I was looking at. But there seems to be a bit of a conundrum here: If the transmitter’s off, why does it matter where its throttle stick is? As I said, with mine the Rx failsafe sets the throttle to zero when it loses signal from the Tx, so it seems like I maybe need to reconfigure my Rx failsafe, though I’m not sure I can make it send anything less than minimum-throttle PWM value. I need it to be at least 20PWM below minimum throttle so that the failsafe value can meet both conditions.

So for me I dropped the throttle to zero and then set the FS value to 10 points below…then modified it up or down till the message went away. I never found it to work like the documentation. I just tweaked it till the error left.

By the way, the FS_THR_VALUE is only really important if the receiver is one of those types that pulls the throttle low to indicate it’s lost contact with the transmitter. If the receiver is setup to send no pulses when it’s lost contact with the transmitter then you can set FS_THR_VALUE to any really low value (like 900). Just make sure to test that the failsafe works when you turn off the transmitter (the method is described on the wiki)

Set the receiver for NO PULSES. For receivers like the X8R and X6R you do this AFTER you bind the receiver to the transmitter. The process is simple… With the transmitter OFF power up the receiver that then press the FS/Bind button for 2 to 3 seconds.
When you release the butting the LEDs will blink and then the RED LED will blink to indicate the TX is off…

In the radio you go to the Model setup screen 2/13, scroll to the bottom until you see Failsafe. In the next column is the failsafe mode. Set the mode to No Pulses.

Now you can connect the FC to Mission Planner and verify that the throttle PWM value goes well below the full low throttle value when you turn the radio off.

Now you should have a working “loss of signal” fail safe and you should be able to arm the motors using the radio.

1 Like

Thank you everyone. So Rx F/S set to No Pulses is the key to getting the low PWM that the documentation is referring to. I’ll do that today.

Now we’re getting somewhere! I’ve reset all my Taranis Tx ranges to 100% and recalibrated in MP. I’ve also set my receiver’s failsafe to No Pulse. Now my ranges show up in MP as 982 to 2006, and when I switch off the Tx the throttle goes down to 821. I’ve set the Thr FS to 970, and the MP screen confirms that it goes into FS mode when I do that.

So I’m now able to arm the Pixhawk, and I’ve checked the motors operation and direction, but there’s a way to go before I feel ready to comit to a test flight.

Thanks for your help. No doubt I’ll be back when I get into the fine detail of all the parameters.

1 Like

good to hear all is working out for you. There is a great community here that likes to help.

Cheers

Servers by jDrones