Newbie question on setup Pixhawk and ArduPilot

As a complete newbie I’ve not been succesful in setting up my ArduPilot on a Pixhawk. I hope someone could help me to get this solved.

My hardware is:

  • Transmitter: Radiolink AT9S
  • Receiver: Radiolink R9DS (set to SBUS&PPM communication)
  • Contoller: Pixhawk 2.4.8 (connected to receiver on RCIN)
  • GCS: QGroundControl v4.0.11
  • ArduPilot Firmware version: 4.1.0

Steps taken:

  • Connected all devices
  • Receiver was succesfully bound with Transmitter
  • Pixhawk connected to laptop with USB
  • QGroundControl started, succesful connection with Pixhawk
  • Uploaded firmware
  • Frame type selected (Quad-X)
  • Radio Calibrated (Mode 1, all 10 channels respond succesfully)
  • Sensors all succesfully calibrated

So far it seemed all OK, but now I wanted to setup a simple servo to be operated with lets say, channel 6 which reponds to the VrA knob on the transmitter. I connected the servo to AUX1, connected 5v to AUX6 and that’s where I got stuck. I tried several options (like configuring Cam tilt to Channel 6) but the servo will not move.

I hope there is someone who can help me getting through these first steps. I’ve been googling and iterating options, installed several firmware versions (both from ArduPilot and PX4) but none of these actions helped me getting the servo up and running.

I’d be extremely grateful by the hint helping me out.


If you are using Arducopter and not PX4 1st you shouldn’t be using 4.1.0 as a “complete newbie” as it’s a DEV version. Use current Stable. If you are using PX4 you are in the wrong forum. Assuming Arducopter and you want to control a servo on AUX 1 from an RC chan 6 input then set:

One other CRITICAL POINT: Use a separate +5 volt BEC to supply power to the servo.

IMHO, using qGround Control to setup and configure a Pixhawk running ArduCopter/ArduPilot is a bad idea. I have tired it and “stuff” was missing. Using qGC for your ground control station (GCS) software is fine.

Thx for your clear and effective advise. Great help! The reason for installing the dev firmware was that I did not succeed with any stable versions. I’ve now gone back to the stable release of ArduPilot.
Using option 56 for SERVO9_FUNCTION indeed was the solution. I’m a bit puzzled by the number of SERVOx_FUNCTION. Why is this nr 9 for AUX1. Is that because they start counting at MAIN1-8? Is there a place in the docs where I could have found it so I could have found out myself?

Thanks for the reply, you’re of course fully correct that is more appropriate to use the genuine ArduPilot softrware, but I’m bound to linux, and Mission Planner does not run stable under Wine. And I’ve not been able to connect over USB using VirtualBox.

Thanks for the not about the separate power, I had indeed connected a 5v power added to AUX6

Well, since you are bound to Linux, maybe you should be using the PX4 firmware and qGC.

Yes, right. If you page down at the end of this link there is some detail. Of particular importance is the BRD_PWM_COUNT parameter and it’s effect on pwm or GPIO assignments of the AUX pins.

That’s indeed a good suggestion. I started with PX4, but as I did not get any further I moved to ArduPilot. Still I have no good idea on which grounds I should choose for one of them. So far I’m not very demanding (no fancy plans so far), notmore than flying a quad drone with a camera+gimbal and possibly some autopilotting.

Thanks for pointing me there, dkemxr, this is indeed very helpful and gives a lot of info
Great help!