Newbie needing advice

Ive built my first 690 hex frame kit, comprising 3510 motors with 35A Hobbyking esc’s and T-Motor 1345’s
Pixhawk mini running Ardu 4

i can seem to get rid of the dead zone from -100 to say -20, in manual mode its okay.

Before my first test flight, and without a disaster, how can i create a curve similar to my DJI Inspire / is it possible?

Is there any way to test the telem port? i have a mavlink led controller plugged in and its stopped working?

If the vehicle is either disarmed or armed and I physically move it i am getting constant attitude and compass alarms ? there a pain.

ive spent many, many hours on this and I dont want to total it first time out.

Is there any way to ensure the esc’s are calibrated. I f i connect the esc cables to the receiver instead of the FC the throttle curve seems good



What are these numbers in reference to? We usually discuss throttle output in terms of 1000 - 2000, 1500 being mid. Or, 0-100% transmitter stick.
I’ve only flown a DJI a couple times, but those had the throttle stick centered at idle, while ardu has it all the way down. So, that is definitely different and cannot be changed that I’m aware of. And if you’re in an auto mode, it won’t start to lift off until you get above mid throttle.

You should not be getting constant compass alarms… I’d suggest redoing your compass calibration, possibly outside, away from anything metal and w/out any power lines in sight.

Have you been through the entire tuning guide?

The LED’s were working then stopped? Did you change any settings? What LED controller are you using? You can scope the output, or hook up a modem or other serial device to see if it works.

What ESC protocol are you using? You can usually tell by the beep codes if the calibration was successful or not.

You can set a parameter for a spring centred throttle ( I can’t remember how it works in manual throttle modes though, so be careful.
The throttle dead zone is also a parameter, although I’m not completely sure that’s a problem here.
To test esc calibration, do a motor test (props off) to make sure they all kick on together.

The esc’s move at the same time around 8% setting on MP. When I connect them to the jumper R8 receiver I get a linear throttle movement from idle to max, however when connected to the Pixhawk , and no matter which mode I select I get a dead zone from
-100 to - 20 then a very erratic throttle response from there to +100. There is no way I could attempt to fly like that. If I run up the motors to say +50 then move the throttle back to mid point the power to the motors stays at around +50 for a second then drops quickly to almost idle and MP says crash and cuts the throttle. Any idea please. Using a Jumper T16 with Open TX and a Pixhawk mini running ardu 4.0.

I think the problem is that you are relying in bench testing. The flight controller expects the drone to take off, but it doesn’t since there are no props. So it increases the Motor output until it assumes the craft has crashed. Same goes for the control logic, trying to keep your drone stable.

I think you should check your Motor orientation and then just go for it…

Motor orientation is good. I shall wait for a calm day and try a transition to hover !

Chaps need your help if you don’t mind.pulling my hair out. Holybro Pixhawk mini, need to switch a relay which has an opto isolated 5v logic. All the posts show relay pins on a full Pixhawk not a mini which doesn’t have any aux ports. Using arducopter 4 on my pix with a jumper R8 receiver. ALL I need it a pin controlled by my jumper T16 switch which toggles 5v hi and low. Any ideas please?