Newbie - F450 + APM2.6 + E300 - Single slow motor spin up

Newbie Warning

I’ve setup a new F450 with APM2.6 with new firmware. Installed the DJI e300 motor/ESC/prop combo and everything works and spins the correct direction. However once armed and throttle increased, 2 motors spin immediately at say 1020 signal, the third at 1040 and the last at 1055.

From what I’ve read, with the DJI E300 kit the ESCs are not able to be calibrated. I’ve tried and just get continuous beeping with no change in symptoms.

The slowest motor was on #4 and I’ve swapped output 3 and 4 on the Arducopter unit and the symptom moved from 4 to 3, thus indicating to me that the ESC/motor combinations are good on both legs and problem appears to be with arducopter output on channel 4.

I know we shouldn’t do this, but I also played with throttle trim and increased it significantly until my low throttle signal was ~1018 and that seemed to help close the gap between the motors for some reason, but it didn’t completely alleviate the problem.

I’m not sure if I have a significant problem or if the arducopter will balance everything out fine once in the air.

Any suggestions?

Thanks, Joel

The imbalance was definitely noticeable in flight (almost flips over on takeoff), but perseverance finally paid off…after trying 5 times to calibrate the ESC’s, including multiple times I tried to individually calibrate. I finally tried all the ESC’s at once 3 times in a row and magically I got the proper tones. Immediately there was consistency in the spin rate of all motors and flight was very well balanced.

Now on to undoing all the throttle curve and ratio changes I made trying to get the unit to respond properly.

Moral of the story, don’t always believe the manual, even if it states it in bold print.