New Pixhawk, Can't load firmware for Y6

Just completed new Y6 build, plugged into Pixhawk following the steps in the MP and I keep getting error message “Error no Response from board” Tried unplugging, pressing ok and re-plugging in but same result.

Any help would be appreciated. I have GPS, safety switch, piezo, compass and I2C plugged in.

Sometimes the computer USB port has not enough power for the Pixhawk.

Please try with a powered USB hub or by powering the Pixhawk with the power module, if you try this last option, remove the propellers first.

Tried with power added same result. MP times out with ERROR: No Response from board and a pop-up window that says Error uploading firmware.

Both my FMU bootloader mode & I/O bootloader Mode LED’s are solid.

Is the board detected by the computer?

In windows is detected as PX4 FMU (com x).

I’m not sure in MAC, I think is detected as usbmodemx

If is detected make sure you are selecting this port in MP and 115200 baud rate.

Try another USB cable or another USB port.

You also can try this procedure:

If any of this worked, please contact