New APM2.5: suspect hardware problem


I just set up my new 3DR Ardupilot 2.5 for the first time. Everything went well, drivers installed OK, they show up as COM5. Mission Planner installed and ran OK, uploaded plane firmware 2.76 OK to the board, firmware verified OK. Connected for initial setup OK AT FIRST, then during compass calibration the connection was lost and LED turned solid red. It will not reconnect. When I plug it in I get a blue LED indication initially by the PM connector and then it turns red. Clicking on “Connect” gives a blue LED for about 3 seconds, then turns red. Mavlink (which initially connected OK) now times out.

I suspect a hardware problem on the board. How do I get it serviced?

Where did you get a 2.5 from?

Try resetting it first … interface/

Tried resetting it - no different, still won’t connect. Powered down and up again, still no different.

It quit working right in the middle of compass calibration. Abruptly stopped taking samples and red LED lit up.

I bought it direct from 3D Robotics.

If you can use the Terminal Tab to get into the CLI, you might try and do an eeprom erase and reset.
From your symptoms, you might have a defective 3.3vdc regulator on the APM. The regulator powers the INS components and the compass. You can try and measure the 3.3vdc on the APM I2C connector to see if it is really 3.3vdc.
TCIII Developer

Can’t access the board at all any more. LED lights up but that’s all.

What is 3DR’s repair policy? I can’t even find a APM2.5 on their site any more.

Hi Kallend,
I think you need to contact 3DR directly at the support EMail or phone number directly from their store: … from+Store
Best Regards,