Servers by jDrones

New Antenna Tracker AVR(APM2) Release


(gmorph) #1

Hi all. I have an AVR (APM2) based AntennaTracker. I’ve pulled some of the newer features and fixes from the Master branch across to the AVR branch and created a 0.7.4 BETA build. It should be available in a few hours once the build server finishes. Love to hear from anyone keen to test it to ensure I didn’t break anything. Again this is just for the older 8bit AVR based boards i.e. APM2. Once tested and confirmed all is ok I’ll create a stable release of this version.

Changes:

  • Sanity check home location parameters
  • Calibrate gyros on accel cal and trims
  • fix start lat/long sanity check
  • request baro pressure from vehicle at 1hz
  • parameter descriptions for FORMAT_VERSION
  • Added for SYSID_SW_TYPE and pitch and yaw PID parameters
  • Always call loadall - ensures defaults file works on first start after erase

The pull request containing the code changes for those interested is below. I mention it as I also put in there the harder changes I haven’t pulled across yet.

Thanks, Grant.


(Linus) #2

thanks grant! this is what i wanted some time ago. will give it a try.


(Linus) #3

Okay maybe dumb question. how do you upload master-AVR to your apm2 board ? i compiled on linux but didnt get a .hex file as i expected. maybe if it works we can provide binarys again later here http://firmware.eu.ardupilot.org/AntennaTracker/beta/apm2/

EDIT: found it!

/usr/bin/avrdude -c wiring -p atmega2560 -P /dev/ttyACM0 -b115200 -U flash:w:/tmp/AntennaTracker.build/AntennaTracker.hex:i

did the trick :slight_smile:


(Linus) #4

I have uploaded the code to a Micro HKPilot Mega and went over the parameters.
it is working in test mode now.
couldnt get it to track a sitl plane yet.
I tried with mission planners pass serial functionality and mavproxy tracker module.


(gmorph) #5

Hi Linus. Are you saying there is a problem or your still trying to figure out how to configure it correctly?

Thanks, Grant.


(Linus) #6

Hi Grant, thanks for your answer. I got the tracker to do something but willI try an second attempt later the day!I think i might have an issue with my radio on the tracke to resolve.


(Linus) #7

Hi again,

i did another attempt but no luck so far.
I think i have configured the tracker correctly and tried with a SITL plane flying around.

sim_vehicle.py -A --uartC=uart:/dev/ttyUSB0 -v ArduPlane -L NFSC --console --map

The Tracker is in auto mode and has GPS lock but refuses to move servos.

Trying to arm the Tracker (mavproxy tracker module) does nothing (trying with MissionPlanner it will say that it refused the command). Do i even need to arm the AVR-tracker ? there was no arming switch implemented back in these days i think.

The tracker level command makes the telemetry dongle flashing rapidly but no output still.
I can switch the tracker to manual mode but not back into auto from MissionPlanner.

It looks like mavproxy gets confused and mixes up the vehicles somehow.

I have tried with sys target ID 0 (autodetect) as well as the ID of the SITL plane.
SITL-tlog is attached but i couldnt get the log downloaded from the tracker.
both apmplanner and missionplanner failed to list logs of the tracker, tried to download with the console and over mavlink.

flight.tlog (905.3 KB)

Do you know if there is another way to retrieve the logfile ?

Thanks for your Help Grant!
Linus


(rmackay9) #8

Yes, I don’t think MAVProxy deals with more than one vehicle well.

The tracker is setup so that it receives messages from the vehicle directly over the radio? I.e. the tracker is between the vehicle and the ground station? That’s how it is best setup I think. I guess you’re using SITL so I’m a little unsure how the setup should be configured.


(Linus) #9

Hi Randy,

ok thanks for confirming. Thats probably why there is a tracker module.

I want to have the GCS in the middle setup and had that working before but pitch didnt work with 0.7.2.
Is there even a way to use the tracker in the middle with AVR hardware ? I thought that was a >APM2 only feature.

Right now with using SITL the plane sends directly through a radio to the vehicle via the ‘-A --uartC=uart:/dev/ttyUSB0’ switch.
I have no real vehicle with me but will try again the next few days.

PS: I think adding a raspberrypi with apsync to the tracker is the way to go for me but first need to get this apm2 tracker doing its thing.


(Linus) #10

If i attach the tracker to a real vehicle (bbbmini, AC3.6-DEV) it starts to work.

This is my camera tracker btw not an antenna so it only needs one radio.
But not having a second link for configuration while tracking is a big downside.

I need to dial in pid’s next as it is little wobbly right now and need to find a solution so i can tune it using SITL.

Big thumbs up Grant! I really like it that we can use our old AVR Hardware for the Tracker again!
Cheers
Linus


( research air) #11

Hi, has anyone worked out using the tracker for camera and ant. use ,Tridge needs videos and I have no friends,any help would be great,…thanks in advance
Rick


(Linus) #12

Hi Rick,

i didnt came much further than testing it at home https://www.youtube.com/watch?v=wya-PRf3K9Q
sorry.

Cheers
Linus


( research air) #13

thanks, Linus, I will give it a go
Rick


(RANND) #14

Grant, Do you have a hex file for AT 0.7.4 squirrelled away anywhere? I realise that support for APM2 has ceased. I have searched unsuccessfully to find old/archived online files relating to 0.7.4. I am trying to convert from a MP-Ardutracker/Arduino solution to an APM2/AT solution. I have tried AT 1.0.0 and AT 0.7.2 on a APM2/GPS combo with 3DR radios between AP and AT, but no go. I get half hearted to non-existent pan performance on both versions. I haven’t tried tilt yet.
Any help would be appreciated. Regards, Don (Canberra)


(rmackay9) #15

I think it should be possible to use the mission planner to load the old software. I’m not totally sure but I think it should be possible.


(RANND) #16

I thought the same. The current and recent versions of MP won’t let you touch AT 0.7.2, 0.7.5 and 0.7.6 and either give an “unexpected error” or arbitrarily start downloading an AC version instead. I went back to MP1.3.20 to load AT0.7.2, but it doesn’t appear to work on APM 2. Neither does AT 1.0.0. I have not been able to find any of the AT 0.7.4 files. All of those versions might be ok for Pixhawk. I am looking for an AT version that works on APM 2. I will continue my search for 0.7.3, 0.7.5 and 0.7.6, but 0.7.4 is the version with claimed APM 2 functionality.