Never seen this one before (was oscillation-now FIXED ) but strange autotune event

This is 12th quad I have here now…the fourth large quad with a Pixhawk cube (Px2) as the FC.

stats: Tarot Peeper 750, no stock electronics at all
Xrotor 40A motors, Tarot Martin high efficiency 4008 330KV motors Tarot lightweight 17" folding props
Pixhawk Cube as FC 10AH 6S battery
Taranis X9D xmtr and X8R recvr. GPS is on top of white dome(offset from CG via Mission Planner settings)

Settings in Mission planner have the flight controller properly offset forward and above the CG as the FC is under the white cowl (custom) near the front of the craft (battery is nearly centered in the main body)
Q- should it really be offset from the craft CG of the quad… or from the plane of props?

The attached log has four landings (checking autotune pid changes) the video is just one flight to hear the sounds its making (turn up the volume and listen to the oscillation). Roll pitch and yaw seem to react fine to the sitcks…just a bit of altitude float (I know I know some tuning still needed. The problem is the osc is so bad when I re-center the sticks after repositioning the osc is bad enough it doesn’t go back into the autotune cycle. I have to snap the stick , will get just one autoune roll…then it stops.
I changed the ESCs (from stock to the Xrotor 40’s) thinking it was a sync issue. None of my other quads or big ass HEX do anything like this.
linked here is the video, a log file an a screen cap of the current pids (have no clue how far off they are…don’t look like any of my other large or small quads
An auo-analyze of the log show a couple issue, but not somethingI’d expect to cause this type of osc.


video of one flight to see and more importantly, listen to the oscillation
Tarot Peeper 750 oscillation

And the log file (zipped)
ptegler-peeper750-oscillation log file

REALLY lost here


Pids seem high try manually tuning it: Change the top 3 setting to 4.5
second line first 3 setting to something like .180 or .125 or just use the slider in basic tuning menu.

Calibrate radio, compass ,escs ,and check prop size sometimes a bigger prop will soffen flight or you can try to reduce props.

Try dropping the throttle accel P and I to half, i.e. P to 0.25 and I to 0.5 and see if that helps.

Neither of my two other large craft have ever changed from stock t acc rates and neither
have ever done anything like this…not even a little…

…my Alein H680 (nearly identical electronics) on 15" props has the following PIDS (auw 3.2kg)

and my 1050mm HEX is in the 14s and 12s for S rates and P rates (auw 5.1Kg)
(15" tri-blades same 330KV motors 6S 10AH)

So I figured this should be somewhere in between

Peeper in trouble pids for comparison follows (auw 2.5Kg)

I really need someone to review my log and see if it’s a vibe issue, even though an auto analyze only grumbles at the vibe results


oh bugger… the other two big craft are 3.4.6 the Peeper is 3.5.5??
hhmmm… maybe I should back up …reload earlier firmware and see if the issue disappears

Just wondering why you changed the PID’s from stock before attempting an Autotune?

Have you tried resetting the parameters and starting from scratch with default settings?

1 Like

ok… testing imminent…have Ch6 set to adjust D in flight… reloaded an older firmware rev… then reloaded AC 3.5.5 (maybe should have test flown while 3.4.6 was loaded but…)
the idea was to make sure a valid firmware load had transpired

This update is more related to noticing an error in the terminal window behind Mission Planner

…oddest part… with/without the xmtr on, and then even with the copter (FC) unplugged from the PC the above error continues to scroll by



The video and this string of questions is after 7 autotune attempts. Yes…after third run attempt they went back to stock… didn’t seem to change…well nearly negligible visual or audio diff in operations. Even changing ESC’s (testing sync issues) still the same osc.

It’s actually the sound as much as the craft ‘flutter’… kind of like two oscillations going on at the same time. One is the speed change…and the ‘whistle’ is a sparate oscillation (sounds like the motors scraping but it’s not) It responds reasonably sharply to flight inputs without problem. It’s just the wobble/flutter and the sound that stops me from even bothering to try mounting the camera gimbal


Have you hard mounted the FC.?

Pixhawk 2 (cube) …internally vibe isolated. Same mount config as my other two large quads
auto-analze does say…
Test: IMU Mismatch = WARN - Check vibration or accelerometer calibration. (Mismatch: 0.99, WARN: 0.75, FAIL: 1.50)


Yea hard mounting is the way to do it I use two sided tape. I looked at your log under vibration in z you are clipping over 30 %. as long as your hard mounted that one issue off the list. did you tune the pids down yet?

wow…what an evening. Today’s testing proved it was worthwhile though. I too thought vibrations to be the issue, but on the bench the logs showed good. So… I did some hardware analysis and changes…

video of changes = mechanical changes

Replacing them was a pain, but paid off. Before and after logging for the three axis…

X Axis

Y Axis

and the Z axis

And for those that mentioned my PIDs (top of this thread) seemed WAY high…
the following shows the post autotune PID’s. She now flies as expected! VERY locked in

Then… of course I had to be a smart ass and going screaming across the yard (post pid eval)…
ended up slamming the sticks over to stop the momentum… added a bit a yaw by accident…turned it on end, slamming (luckily) into a rubbermaid yard storage bin. Copter took it well but damaged two blades.
Still put it back in the air to show the wife the difference, but it sounded like a buzz saw with pieces of loose carbon fiber flapping, but was super stable regardless.

So… My over all impressions of a Tarot Peeper 750? I love the frame and arm design. stock electronics force you to use their FC (so I gutted it all and added the Pixhawk) The motor mounts are crap. Over all though I like this quad alot! Folds up very FLAT and performs well (when you remove the idiot at the sitcks)

Need to replace two 1/2 blades and will post a post tune vid to match the initial osc vid


lots of play on the old mounts dam. . could be why you needed high pids to over come loss of rigidity.

first set of pids was the 3rd?-5th? attempt at an autotune.
Last set is what is working, and are closer to my 4-5Kg Hex (tri-15" blades) than it is my heavy 680 (with flooding 15" blades) all have the same motors/escs

yep…have to believe they were acting like little springy cantilevers to the motors. Speed changes would flex and spring load the arm causing motion overshoot and the initial oscillations

hmmm crap…don’t have proper spare props on hand…looks like I damaged nearly all of them They really are SUPER lightweight and thin props. a couple cracks, some delams, tip chips, Plenty of spare Tarot 15" folding on hand, as well as lots of single carbon fiber blades…but would likely have to re-tune :frowning:

Oh…one other ‘change’ last night… I placed two layers of Mu Metal shielding between my vid xmtr and the Pixhawk as they are pretty close together…might (might not) have helped with noise


hehe… seems to be a one sided thread here…
but that’s ok…if not at least entertainment, learning experience for those reading it

Still my first Q was never answered…
Mission Planner facilitates setting variables to define how far from your CG your FC is mounted (just like your GPS sensor) My Q… Should it really be CG or the plane the blades are on…set the x,y,z distance from CG or blade plane (power plane) as that seems to be the ‘table top’ that tips/angles the craft.

also tonight…found another issue never encountered before… (for developers…timing issue in a loop?)…
Since I wiped out a set of props last evening (being stupid) I installed a 15" set (orig was 17") So I went through a full autotune,if nothing else to see what the PIDs might look like.
That was NOT a good move. Roll and Pitch worked just fine…YAW was running when I noticed stick corrections to relocate the craft back to the center of my flight area were going wonky! What I mean by that, yaw autotune started… goes through a 5-7 twists, …as I gave it left stick to move left a bit to recenter my flight area, the craft pitched forward not left. A quick correction attempt (pull stick back the craft rolled left… next quick correction…the sequence had rotated again so now a correction to attempt to roll back left, the craft pitched back! OH CRAP! started chasing the response needed vs what it was doing… switched off autotune and the rotated sticks vs control locked 180 degrees rotated. Forward stick was back, right stick was left. That’s about the same time I took out the wrought iron stand/brass sundial in the wife’s I’d lost about 10 ft in altitude and was not about 40 ft away from where I tune.

Again all of this is nothing I’ve ever experienced. Then again, this is the only craft running AC 3.5.5 I lost the logs

I only lost three (1/2s) of the plastic props, but put a nice dent in the metal tube arm of the Peeper Logs were lost with fast battery disconnect ^^&#$@#~!!!


I be honest your pid look really bad. I would reset your pid to stock and do not use auto tune I not surprised your craft is flying like it is.

Pids are like a graphic eq or a wave.

changing props do not make a issue normally. I go up and down sizes to test KV for stress, motor heat and flight times and 3 cell or 4 cell use. Stick with 3.5xx

pids had been reset at least once before the first video. and over the course of a couple autotune sessions after wards The last pid set (graphics above) are now working great! (and are along the ranges of my other large craft.

yep…15" props barely changed the pids… will leave them as is as I have more 17’s on order


Ok Kinda sounds bad but any landing is a good one. cheers.

Odd that you would have to re-position the craft at all during Autotune. Were you in PosHold during the process? Yes, it will move around within a fairly large radius but I have never had it wander away enough for re-positioning since PosHold Autotune was enabled. I run it in my backyard at an altitude above the local trees and it works well. When Autotune works well that is, I typically tune manually these days.