Need position estimate despite 3d fix


Anybody know what input needed to get rid of " need position estimate" message.

Despite having 3 d fix on both modules, and both grond station and drone shows pn the map, its not possible to arm.

Tried to both enable and disable the fence function, but no impact.

I had the exact same setup with 4.1.5, and worked without any problems.

This isn’t always enough for a sufficient positional fix. Wait…

1 Like

Yes, i know that, but after waiting 25 min, it starts to get boring…

Did you see a message like this?

No, thats the strange part. There is no faulty codes whats so ever. Just need position estimate

You could set disarmed logging and post a link to the log.


The message means that the EKF cannot calculate a good position estimate using the sensors it has (normally IMU, baro and GPS). Even if the GPS reports “3D fix”, its output can be very jumpy or does not match what other sensors are reporting.

It is unlikely to be a software problem, more likely it is an environment problem although it can also happen if the accelerometer or compass haven’t been calibrated. Also make sure that ARMING_CHECKS = 1 so that any problem are displayed.

The vehicle is of course outside with a good view of the sky?

1 Like


I keept on struggling today, and will try some other things tomorrow.

Basicly i went over everything today. This includes downgrading to 4.1.5 ( worked before with simular hardware and setup ).

Got the same issues, so i upgraded to latest stable version ( 4.3.3 ).

The setup is Cuav X7 Pro. Two Cuav RTK 9Ps configured for yaw control.

GPS_POS1_Y = - 0,235
GPS_POS2_Y = 0,235
The antennas are 47 cm apart on y-axis.

I even upgraded firmware in both rtk, and checked them with cuav software.

Yes, it doesnt matter were i try this. Outside on an open field, with 1 km to the nearest house.

I will enable all arming checks tomorrow, and try to post a logg.

Depending on armingchecks, i got almost every message there is.

Set ARMING_CHECK,1 and LOG_DISARMED,1 and lets see a .bin log
If you can get a suitable fix to allow flying that will be handy too.

Set LOG_DISARMED,0 after you’ve gathered this log and uploaded it somewhere.

@xfacta @rmackay9

The logfile is to large to upload, or its me that doesnt know how to do it…

Anyway, i did a lot of tests today.

Now, the original konfiguration is:

Quad 28"
Cuav X7 Pro
C-RTK 9Ps ( two )

The RTK is setup for YAW ( 17 and 18 GPS_TYPE )

I previosly used this setup with 4.1.5, worked without any problems. Now i tried to upgrade, and downgrade ( erased with changing to rover and back ), but still have a main problem with compasses, and from the beginning 3d fix.

This was the first problem, " Need position estimate " despite it has 3D fix and RTK fix. After several attemt to calibrate ( works every time ), it always start 90 degress of to the left. All is mounted correctly, and i tried to recalibrate without rtk modules, but same problem.

Next step was to recalibrate again, and now i got GPS of with 90 degress, and both rtk yaw 270 in orientation??

I even tried to replase the RTK modules with two NEO 3 Pro gps´s, and the got exactly the same problem. I´m leaning towards that this must be a hardware-issue with the autopilot, because nothing makes sense.

It started with " need position estimate", then “compasses inconsistent”, " GPS (2) yaw not available" and alot more. It seems like everytime i restart the autopilot, it comes out in another configuration with different issues.

I plan to try replace the autopilot with a new, and reconfigure everything from the ground up.

What is your thoughts?

It usually is. Use a cloud service (dropbox, etc) and past a link to it.

In this case, we don’t need much of a log. Power up. Wait a few minutes for things to get as stable as they are going to get. Set LOG_DISARMED=1 for 5-10 seconds and then back to 0. That should be enough.

Do you mean that i change it when the power is on?


Correct. 0 to 1 to 0 during the same power cycle.

Ok. Will do


Even try to arm so warnings or errors are produced.

When you do get a .bin log file upload it to dropbox, onedrive or google drive, something like one of those, and provide the sharing link to it here.


By the way, Mission Planner has a reset parameters feature so you can skip loading another firmware on there.

@rmackay9 yes, but i wanted to make sure that nod id table got cleated as well.

@rmackay9 @Yuri_Rage @Yuri_Rage

So. I started over again, just to make sure it was i fresh setup, with no old parameters around.

I follow the checklist i used for the past tree years, when configured my drones. This includes the Xer X8 and X12, that i developed over the past years. For example the X8 with hybrid engine works perfect with this exact setup, however it uses the 4.1.5 version.

I uploaded the checklist and logs here: QUADLOGS - Google Drive

After initial setup ( in shop ) according to uploaded checklist, i went out to the field, with no magnetic interference at all.

At the field:

It however shows heading 90 degrees of to the left.

After calibration, both rtk modules shows a YAW offset of 270 degrees. This is despite that i didnt check the box “Automatic lern offset”.

Started RC controller and waited a couple of minutes. Still shows 90-10 degrees of to the left. Then i moved the drone around abit, and suddely it started showing correct heading.

Tried to arm in “STABILIZE”, and it worked.

Change to “LOITER” and got " Prearm: “GPS(2) YAW NOT AVILABLE”. Tried to arm anyway, didnt work.

Change to “ALT_HOLD”, and managed to arm.

Change back to “LOITER”, same result: " Prearm: “GPS(2) YAW NOT AVILABLE”

Restarted the drone, and again got GPS1 3D FIX and GPS2 RTK FIX. Shows 90 degrees of to the left.

Able to arm in “STABILIZE”, but not “ALT_HOLD” or “LOITER”
After 3 min the GPS1 changed to 3D DGPS.

Manually changed the COMPASS_ORIENT 2 and 3 to 0 instead of 6 and restarted the drone.

After restart it still shows 90 degrees of to the left…
Unmarked “Use Compass 1” ( internal), and restarted the drone.

Still schows 90-100 degrees of to the left, and " Prearm: “GPS(2) YAW NOT AVILABLE”.
Able to arm in “STABILIZE” and “ALT_HOLD” thou.

At this stage, i just tried to rule out errors. So i switched the RTK modules positions, to make sure that the GPS_POS1_Y and GPS2_POS_Y was correct.

Restarted, and got the same result, 90-100 degrees of to the left.

Now i unboxed the use of compass 1 ( internal ), and restarted the drone.

Result: Off by 90-100 degrees to the left, GPS1 3D fix, GPS2 RTK fix, able to arm in “STABILIZE” and “ALT_HOLD” but not “LOITER”.

I hope you guys have some input… To me it seems like a possible hardware issue, but the autopilot and rtk´s are brand new, and after this accured from the beginning, i even updated both RTK modules firmware to the latest.


This afternoon i tried with a different autopilot, with the exact same setup. And, got the exact same result.

Used the original autopilot again, and changed both RTK´s modules. And got same result after calibrating the compasses with the right nod-id.

This time it also starts 90 degrees to the left. I actually managed to get it to point in the right direction after moving the drone around a bit, but i managed that in the first configuration as well.

Interesting is that this time it also show 270 degrees yaw on GPS1 and 2 after calibration.

Log file from latest test with two new rtk modules is also uploaded were it arma in “STABILIZE”, “ALT_HOLD” but not in “LOITER” because " Prearm: “GPS(2) YAW NOT AVILABLE”.

Logfile name: 2023-01-25 14-38-03.bin

The other four logfiles is from the first test.

AND… please dont mind the cables, the lack of attachment is because of this testing…

So, it seems to me that two autopilots cant be faulty, and not two rtk-modules. Did i miss a parameter somewere, or what going on?..

@Yuri_Rage @xfacta @rmackay9