Servers by jDrones

Mysterious Resetting of Flaperon Trim Values (Solved)


(jacques_eloff) #1

I have my quadplane setup with flaperons which, together with the inboard flaps, allow me to create camber over the full length of the wings for nice slow loiter. On a number of occasions when booting up the aircraft I have noticed that one or both flaperons are deflected which requires me to go into Mission Planner and manually reset the trim values. This does not happen all the time, just seems to be random.

To confirm, I am using Flaperon_Output function on RC13 and RC14. I have my flaps set up on RC10 wih RCn function=2 (flap) and this is also my FLAP_IN channel. Firmware is 3.7.1 but this was happening on 3.6 and earlier too.

Also, I recently did a radio calibration and noticed that as soon as I finished the process, both flaperons immediately went into the up position and again I had to go and manually change the trim values on RC13 and RC14. This happens every time I do a calibration.

Any thoughts on why this can be?

Thanks,
Jacques


(jacques_eloff) #2

I think I stumbled across the issue.

Futaba 14SG (which I am using) has the last 2 channels, which are digital, mapped to switches on the TX by default. I have disabled them and all seems fine now.


(Alb Cem) #3

Although it has been quite a while since you posted on the topic, thanks for the information you provided for the flaperons in your setup.

Recently on my custom fixed wing drone, I implemented things in the format of crow flaps following the guides on ArduPlane and all appears to work semi-right in Manual, FBW and Stabilize Modes. I say semi-right, because in Manual mode, I have a strange behavior for the ailerons: When I apply the aileron on the RC stick, one aileron goes up as expected, but the other one stays still or vice versa for the opposite aileron throw. In the remaining non-Manual modes both aileron surfaces move in the correct way, one goes up, the other goes down… My RC setup is Taranis and I have not really messed with mixing or trim values there as recommended in the Wiki pages, so I am puzzled why the Manual mode behaves in the way it does. May be, you already encountered this kind of problem and resolved it… any ideas?


(jacques_eloff) #4

Hi, I don’t think I can help with that issue unfortunately.