My SkyViper, Linux, and Me... Help?

I am starting to get a little stressed after several hours of trying to figure out if a way even exists to get my SkyViperGps 2450 to be able to participate in the awesomeness that I see others enjoying!

I run a laptop with Linux, and this seems to be my only option aside from my smartphone (which I don’t think my smartphone has any of the options that my laptop will)… My aim is to find a way to be able to 1) Find a GroundStation software for my Linux based laptop 2) Not look so silly when looking for a GroundStation software for my Linux based laptop…

I’ve actually come across several things that led me to believe that this is possible, but after attempting to build/make/i’mretarded these things I’ve come to realize that most of them are written and geared toward people that actually have a clue to what they are doing… This is my first go at the whole Software based control systems and mission planner. I just can’t seem to find something that can step me through the process of getting set up!

I want to be able to set gps waypoints for my drone so that I can theoretically walk outside, turn it on, push the required buttons, and it take off on it’s voyage of following the parameters that have been set forth for it and for it to return home (or at least as close to home as possible)…

If anyone could lend me some help I would be extremely grateful… I’m pretty sure that I’m on the cusp of having an aneurysm, and there isn’t anyone else around that could feed my dog…

Thank you in advance to which ever Drone Savior Guru comes and reads my prayer request… (Briers dog food is in the 2nd cupboard to the left.)

~The Brier Fox

Kyle, seems that what you’d like to do should be pretty straightforward, with the following steps:

  • Download qgroundcontrol to your Linux laptop. Fire it up, write up a mission in qgc, and save it somewhere. If it’s your first mission, I suggest something simple, like one waypoint 5 meter up, move 20 meter, return to home, or something like that.

  • Power up your skyviper, and connect your laptop to the skyviper network.

  • Fire up a browser to You will then get a web interface to the skyviper, see camera output, etc …

  • Reprogram your transmitter to have one button or button press combination assigned to mode “auto” for an autonomous mission. (see wiki docs)

  • Go to qgc, it should then automatically “see” your viper and connect to it. Write mission to skyviper.

  • Grab your transmitter, arm the viper in gps mode, then switch to auto …

And voila, watch the magic of autonomous flight!

1 Like

Note: Alternatively, you can set the viper in station mode (see wiki on wifi.txt file). Your viper will then connect to your home network. You can then assign it a permanent ip address (by configuring static dhcp on your router for the viper with its MAC address), you will have to sniff it from ip traffic (e.g with tcpdump, look for 14500 udp packets) to find its MAC adress. Then connect your web browser to that IP address, instead of

Assigning a permanent IP address on you router is optional,. If you don’t you’ll just need to sniff every time you connect as a different IP address might be assigned each time the viper is powered up.

1 Like

Apmplanner2 also compiles for Linux, like any GCS application does. Or MAVProxy
… Because you would never trust windows with anything airborne :slight_smile:

1 Like

OliverB . . . this newb hasn’t done a “mission” yet but would the same steps be involved for running Win10 on a laptop? Mind you, I’m already unable to run the SV app on said laptop thru Bluestacks
Not jackin’ this thread but others may want to try this first?
Here’s where I’m at:

Then I select “forget” . . . but fails to forget.

Yes, same steps with win10. In addition you could run Mission Planner instead of QGC it works fine (and Planner or Mavproxy that also run on Linux, although I haven’t tried Planner and mavproxy, although I haven’t tried Planner).

I am unfamiliar with the Bluestacks’ implementation of virtual network interfaces, but I am not surprised it doesn’t work. For it to work it Bluestacks would have to simulate a wifi access point connection with both end points on the same machine.

So, how would I best go about running the same SV app on my laptop that I do on my phone? Others seem to do it no prob.

Jeff, not sure what you mean when you say others can do it with no problem?
You can certainly run an Android app on a laptop (e.g. with bluestacks), but with respect to the skyviper app I don’t see how it can be done.
Edit: hmm, maybe with a private bridged configuration …