Servers by jDrones

Multiple SITL Instance Help

Hello everyone,

I am trying to make multiple SITL instances in Mission Planner for plane sim, and keep getting errors. I am connected to TCP 5760 and want to connect to port 5770 and 5780 (for three planes). I saw a video on YouTube and structured my .bat code the same way. This code was originally for quad simulation:

Code: this is a .bat file. Original video: https://www.youtube.com/watch?v=UxlA2RM92tE&t=581s

start…Arduplane.exe -M plane -s1 --defaults …default_params/plane.param -home 39.050585, 125.779500,10,0 --instance 0
start…Arduplane.exe -M plane -s1 --defaults …default_params/plane.param -home 39.050585, 125.779500,10,0 --instance 1
start…Arduplane.exe -M plane -s1 --defaults …default_params/plane.param -home 39.050585, 125.779500,10,0 --instance 2

When I run this code in the command prompt three windows pop up (as they should) which saw they’re waiting for a connection.

But when I try to connect to the TCP ports I can’t connect. Even though 5760 is the first instance and should run without the other two instances.

Here are some things to know:

  • I have only worked on the command prompt and in the MP interface (not super good at coding)
  • I do not have an autopilot hardware connected. I am only working in simulation

Any feedback would be appreciated

I suggest you look at the muti-cast UDP support for this application, it should make life easier
see libraries/SITL/examples/Morse for some multi-cast launch code

1 Like

Thanks for the response.

This is my first time working with multicast in a mission planner setting, so is each line in your code (start_follow.sh) supposed to be used Cygwin64? Does it output the UDP port numbers used in Mission Planner?

Servers by jDrones