Multiple different compass related problems on Orange Cube and Here+

Hi Everybody!

I just built a new heavy lifting drone with Orange Cube and the Here+ 2 external GPS and compass unit, I did the first flight earlier this year, and it flew great. Two month went by with no flights at all and a few days ago I finally had the time to fine tune the PID settings for further testing, but I was unable to take of. The drone started to wobble and lean and I had ground mag anomaly error message. After that I tried everything, calibration, changing settings, but I’m clueless, since I did not change anything since the last flight two month ago, when it worked fine, and I always had different compass related errors. Also it is impossible to succesfully calibrate the external compass, which is mounted away from everything.
I get the following errors totally randomly:

  • Ground mag anomaly
  • Compass inconsistent
  • EKF variance
  • Mag bad radius

Im starting to think that the external compass unit is faulty, maybe do you have any idea? Here is a link with the logs:

Thanks a lot!

Hi there
In my Orange Cube I also get error regarding the GLOBAL_POSITION_INT stream. When I ask for the velocity in each direction and also the compass angle, it gives me one first group of huge and ridiculous values, and a second group of correct errors.
Maybe it is related with your problem? I am searching but I couldn´t arrive to a solution, but I will keep trying and keeping in touch with you.

Kind regards

Your compass ID’s are mixed up.
Check in mission planner DeviceID section, the one on the I2C must be the external one, and the one on SPI bus is the internal. Your FC close to wiring, then disable the internal compass.

1 Like

That answer is for me or for @Karoly_Ludvigh ?

1 Like

It is for Karoly, your question is not related to the title of the post. You should open a separate topic for it.


Thanks a lot, I will definitely check this, altought Im not sure how it was working fine with the same setting before. Also Im using a Kore carrier board, and there is no other wiring there, than the esc power and signal, and the cables to the herelink, and all of thoose are going directly away from the FC, so I have no idea how I could fix the wiring.

I tried to check, but Im not sure how can I make sure which one is which, and also how to change it so the external would go to I2C and the internal to the SPI. Can you maybe help me walk trhough the setting process?

Thanks, Im very tahnkful!

I contacted you on FB…