mRo Pixracer R15 six PWM outputs, what channel for heli ESC?

I’ve done most of the configuration of my mRo Pixracer R15 on my TRex 500 fbl heli, up to and including setting the collective pitch parameters, using Arcucopter v4.1.1 heli. But now I’m completely stuck on getting the motor running:

All the instructions and videos I’ve consulted say that the ESC must be connected to Ch8. But the R15 only has six PWM outpurs, so I’ve connected the ESC to Ch6 instead. Using MP I’ve calibrated 8 channels in the MP Radio Calibration screen – the four major stick controls for Ch1-4, and switches A, B, C, and D for Ch5-8, all with ranges 982 to 2006, and configured eight outputs in the MP Servo Output screen as Motor 1, Motor 2, Motor 3, Motor 4, RCIN5, HeliRSC, RCIN7, and RCIN8.

I’ve disabled power monitoring and safety switch because I’m not using those functions at the moment, and am able to arm the R15 using the left stick at bottom right corner, condirmed by a long beep and a solid green LED. Swash and tail respond correctly to stick inputs, but no motor activity. In case it’s an issue with calibration of my ESC, I’ve connected a servo in place of the ESC, but it doesn’t respond to collective stick movement.

So what am I missing, please? I see many references to ‘motor interlock’, but I can’t figure out what it is and how it’s implemented. Is that my issue?

Looks like you have the output to the servo rail configured correctly with HeliRSC on channel 6 which is what your ESC wire is connected to on the servo rail. Now you need to configure the input channel from your transmitter for the motor interlock. Motor interlock is basically equivalent to your throttle hold on your transmitter. Choose a switch on your transmitter that will change the transmitter outputs of a channel between high and low. In Mission planner in the config tab select the full parameter list on the left. find the parameter RCX_option (where X is the channel number on your transmitter that the switch is associated with) and change it to 32 which is motor interlock. Now you will have to select an RSC mode for the rotor speed control. If your ESC has an internal governor then choose the setpoint mode, if it doesn’t then you’ll choose the throttle curve mode. Look at the wiki to see how each of those modes work and what do you need to do to set them up. If you have any questions as always post here.

H_RSC_MODE is set at “2”, since my Talon 90 ESC is in governor mode. RC8_OPTION is “32” and RC6_OPTION is “0”. I’ve checked in MP Servo Output screen that flipping my switch D changes Ch8 output from 982 to 2006.

Uh oh! I’ve just noticed that in the Servo Output screen that after I’ve armed the R15, the green bar for Ch6 does move after I’ve flipped the switch for Ch8 from 982 to 2006, but it doesn’t follow the collective stick movement – it starts at 1100 and climbs slowly to 1660 even with collective still at the bottom. I understand that’s the ramp-up that I’ve programmed in, but the problem is it doesn’t result in any movement of the servo that I’m using as a temporary replacment for the ESC, and it doesn’t move any higher when I increase the collective.

I’ve got logging enabled at power-up, so attached is a short log file of a power-up, arm, flip motor interlock switch, wait a few seconds then raise and lower collective. Does it reveal the problem?

79 18-11-2021 17-49-38.bin (796 KB)

A little bit of progress today: The servo I’ve connected to Ch6 PWM output now moves just like the servo monitor in MP – i.e. it ramps up over a period of 10 seconds from 1100 to 1660 when the unit is armed and Ch8 is high. (I’d previously connected it via the ESC input on my home-made power-sharing circuit, which meant it’s power supply was blocked by a diode :blush: ). It goes back instantly to 1100 if Ch8 is switched to low, or the unit is disarmed. Also, I can’t arm if Ch8 is high, which I understand is also correct.

So all that’s wrong now is Ch6 does not increase above 1660 when the collective is increased. In all my helis I’ve relied on throttle curves, so have no experience of using my ESC’s governor mode. Perhaps Ch6 is not supposed to increase any further, and I’m supposed to adjust it to whatever PWM value triggers governor mode in my ESC, because I’ve specified governor mode rather than throttle curve? I’m researching how to program my Talon 90 now.

@abenn1 with RSC setpoint mode, it is designed to ramp to one setting and the setting is set by H_RSC_SETPOINT. Please read this part of the wiki

Edit: yes, you’ll need to use the castle interface to be able to connect the ESC to your computer and program it through the castle creation software. The one I use allows you to set 3 governor speeds which correspond to pwm ranges. You would just set the parameter H_RSC SETPOINT to the pwm of the governor speed you want. Once you set up the governor, you will want to change the H_RSC_RAMP_TIME to 1 second. That way the ESC governor takes over to speed up the rotor to the operational speed by the time the H_RSC_RUNUP_TIME expires.

Thanks Bill. It seems like Arducopter is doing exactly what it’s supposed to do. This afternoon I’ve got my CC interface out of the cupboard, installed their software, and have started programming the ESC. With your reminders about H_RSC_SETPOINT, _RAMP_TIME, and _RUNUP_TIME I’ll soon be good to go.

All done! Working correctly. Thanks Bill. CC reckons that for my desired head speed of 2000rpm I need a 1.549mS signal to the ESC, which it says is about 56.1% throttle. So I just now need to set my H_RSC_SETPOINT to about 1560 instead of 1660 which it’s at at the moment. Then I just have to wait for a good flying day to start real testing.