Servers by jDrones

MP GPS-based Antenna Tracking


(Frankie Fung) #1

This approach requires that the GCS is running on a PC that has access to GPS information.

I have a normal laptop running Windows 7.0. If a Sik telemetry radio is plugged to the laptop, is it considered to have access to GPS information for tracking the vehicle ?

If not, how should my laptop be equipped for this purpose ?

Thanks


(Sebastian Schürmann) #2

Last time I used this, the laptop running MP did not need a GPS. You just had to click in the map at the place where your tracker hardware is located and select “Set tracker home” or something like that. Then it would calculate azimuth and elevation from that location.


(Frankie Fung) #3

Hi Sebastian,

Thank you for yr reply. In fact, I did set the location where the tracker is as home. But probably due to many other reasons, the servos still don’t move.

By the way, you told me Oct last year to use SITL to test the tracker. I followed all the instructions in wiki, downloaded and installed MAVProxy, then when I came to install Cygwin 64-bit installer for my laptop, not all the packages required to select , according to the wiki, appeared. So I was stuck there last year.

I am not a developer, and thus no coding knowledge. Preparing my laptop to use SITL is a great challenge to me. It has been over 2 years since I started this AT “in the middle”project, without success. I will not give up, and still desperate to try to make it work.

To reply to your question in Oct 2017, as follows :–

“ Do you have a GPS connected to the tracker?

If not, it will assume a position somewhere on the equator and depending on where you live, this might be a long distance away from the position your vehicle reports. So even if you move your vehicle, the resulting radial change related to the tracker’s position is so small, you will not see any servo movement.”

The tracker is set as home at a location just few meters away from the vehicle. Out at the field, I fly the quad 4-5 meters above the tracker and over 15 meters across, the 2 servos still don’t move. I don’t know why.

You used u360gts to test the tracker. Does it work ? Can you provide more info ?

Thank you.

Frankie


(Sebastian Schürmann) #4

Just to be sure: Are you trying to get the Ardupilot Antennatracker firmware to work or Missionplanners Antennatracker feature? Those are two completly different things.
To get SITL to run, you do not need to do all this setup anymore. MissionPlanner has a simulation tab where you can select which vehicle to simulate and where it should be placed. It is really simple to use, it works with MP Antennatracker feature and you can output the mavlink information over network or serial to the Ardupilot Antennatracker (or any other mavlink compatible tracker) by pressing CTRL-F > Mavlink.
U360gts is a tracker firmware for a Naze32/Flip32 board. I built a tracker with it and it is working fine. I tested this tracker with Missionplanner SITL in the way I described above.


(Frankie Fung) #5

Sorry for late reply as I was out in the field over the weekend doing more AT testing, and also spent some time to try out the SITL before responding. Thank you for your continued assistance.

I have been trying to get the Ardupilot AT firmware working most of the time, ie. tracker with either APM2.6 or Pixhawk 2.4.8 flashed with AT v0.7 or v0.8.But in between, I also tried the MP GPS-based AT, in which I bought a Maestro servo driver board for testing, also without success. I made a mistake in the title of the thread in the forum and mix up the 2 types of AT.

Pls see the following video on the set up when I tried the SITL. The radio on the laptop is paired to one of the 2 radios on the tracker. Once I pressed Ctrl-F, the temp screen popped up, and I don’t know what to do, as most of the param on the temp window are unfamiliar to me. Where is “Mavlink” after pressing Ctrl-F ?

https://drive.google.com/file/d/1jr3D4rGrWlFgdwEwwxCPa3nKKbH3yoqG/view?usp=sharing

By the way, I started to look at u360gts and found out a thread in RC group. It contains a lot of useful info in English, of course. Does u360gts only support Naze32, not CC3D, As I have got a spare CC3D on the shelf. ? I saw a .hex file for CC3D in the u360gts website.

Thanks


(Frankie Fung) #6

Hi Sebastian,

I further played with the SITL, and found the Mavlink button in the temp pop up window(sorry for my oversight). After hitting this button, 2 vehicles appear. In each of them, different param with frequency and # follow. How do I simulate the motion of a vehicle ? Sorry for the stupid question as I have no knowledge in coding.
I have 2 radio telem on the tracker :-- one pair with GCS, the other pair with the radio on the vehicle. To make the SITL work, which radio on the tracker should the radio plugged to the laptop pair with ?
Thanks


(Sebastian Schürmann) #7

I guess you need two instances of Missionplanner running (on one or two PCs). One runs SITL and outputs the Mavlink stream through the one radio telemetry set to the tracker (CTRL-F > Mavlink) and the second instance connects to the tracker via the second radio pair.


(Frankie Fung) #8

Hello Sebastian,

I finally know how to use SITL. After getting the temp window, I need to press “Mavlink” as you said, then press “Arm and take off” . And seems only Guided mode and Waypoint are supported. However, this only works on Pixhawk set up, not APM2.6 (which has only 1 telem port), probably due to the fact that telemetry port and USB port can not be used at the same time. Also, I cannot arm the APM2.6, so both SITL and actual vehicle do not work on the tracker with APM2.6 as controller.

By the way, I still can’t “fly” the quad on SITL to make the 2 servos move . The servos do move, but seems in random fashion when I set the quad in GUIDED mode and take off.

As for field testing, I have been partially successful, meaning only the PITCH servo responds to the climbing quad, but not the YAW servo. I need to find out why. Anyway, the development last week was very encouraging and thanks for your help so far.

Cheers

Frankie


(Sebastian Schürmann) #9

You can use SITL with a joystick and fly in other modes, too. Do not waste your time with an APM 2.x. There won’t be new versions for it and Pixhawks (clones) are not that expensive anymore.
It has been a while since I last used Antennatracker and even longer since I used it on an APM 2.x, but I can not remember that arming was necessary in the earlier versions. The tracker was controlled with the different flightmodes, if I remember correctly.


(Frankie Fung) #10

Yes, I agree with you not to waste time on APM, and start to use Pixhawk.

May need your help in future if I switch to u360gts.

Thanks.