Moving Baseline with only one serial

I have two uBlocks F9P GPS for use to get yaw and I can configure these GPS for send yaw to each other via RTCM without additional connections with the Pixhawk4. Its possible do that?

BASE --> ROVER --> Pix (only one connection)


BASE --> pix
ROVER --> pix

Someone else may know the answer, but if not, I can test this easily with my setup. I hope to work with my mower tomorrow afternoon if time permits. If I do, I will turn off GPS_AUTO_CONFIG and unplug my Moving Base GPS from the flight controller. That will have the connections just as you are describing. I will see if it works.

Do you have an advance? I use telem1 for communication and the others for radar. I don’t have serial to connect another GPS…


It is certainly possible to configure 2 x F9P modules to transmit/receive RTCM corrections independent of the Pixhawk using their 2nd serial ports. In this case it would need to be the module configured as the rover that is connected to the Pixhawk. You would have to configure these manually and disable the auto config on the Pixhawk. I had this configuration on our vehicles back before the F9P was directly supported.

1 Like

This app note is helpful: ZED-F9P ( Note that section 2.2 gives the messages required from the Moving Base to the Rover.

I made a rather long, boring video in which I experimented with various configurations of Moving Base and Rover if you are interested or if you need something to put you to sleep:

Did anyone else managed to get it working?
On ucenter side, I configured everything correctly, the messages I need are being sent and being received, but I think I getting some parameter wrong, it keeps saying unhealthy gps ,despite the fact that it is rtk fixed

Have a look at this configuration:

ArduPilot simpleRTK2B+heading configuration - ArduSimple

I’ve not yet used that particular setup, but others have reported some success.

I did it, and it also shows in the mavlink inspector, but it seems like the flight controller ignores the gps yaw source

I have since used that configuration with success. I’m still not a fan of that implementation, but it does work.

Hello, just to confirm it, you followed exactly the same steps as they were told in the link? Using MP, the vehicle icon doesn’t react while I change the antenna position to test it, while the value of yaw viewed in mavlink inspector does reacts to it

Yes, it worked without addition to the instructions as set forth by ArduSimple.

Something with my setup is wrong.
I checked that both rover and moving base with ucenter have rtk fixed, with the rover generating heading.I can also see within mavlink inspector the data is arriving as gps2_raw and it matches what is shown in ucenter, but it as if ardupilot chooses not to use gps2 and uses gps1 instead, even through gps2 is set as primary and I also set to use the primary gps.

I also tried updating the firmware but the problem remained.