Mounting APM backwards possible?

Hi people,
I’m new, so this is my first post.

I’m diving into the deep end here. I just built my first tricopter(!), and I’m using an APM 2.5.

Due to the way the wiring is set up on my craft, I purposefully mounted it backwards (with outputs pointing forward and inputs toward the tail). I know this isn’t the intended method, but it is what works best for my wiring.

I’m using OS X and APM Planner 2.0.17. I’ve flashed my tricopter with ArducopterTri 3.2.1.

I’ve tried to take off a few times and the craft just flips over. I’d appreciate any help anyone can give me.

Can anyone tell me if mounting the APM backwards is causing the problem (even after I’ve calibrated its accelerometer and gyroscope)? Or what I need to do to allow the APM to be mounted thusly?

Sorry, I can’t figure out how to edit a previous post… but I might have a different question.

I’m running an external GPS with compass and APM planner accurately shows my location, however the direction is wrong (facing east, indicates facing north).

I removed the GPS from the craft and tried rotating it, but the APM Planner software did not update. However, if I moved the craft the APM software updates. It seems the APM is using the internal compass and not the external compass.

Further, despite running the accelerometer calibration several times, the artificial horizon is still backwards.

Can anyone provide help on making sure that the APM uses the external compass and accepts the settings after performing calibration for the accelerometer?

Take a look at the AHRS_ORIENTATION parameter in Mission Planner.
You need to disable the compass in the APM2.5 if you are using an external compass


although that link was directed at the older break-out compass/accelerometer board, I did gain the insight to go into the advanced parameters and filter by “orientation” to change the board orientation (yaw 180).

There was a useful note that these parameters would not update until a reboot of the board, and accelerometer would need to be recalibrate.

Are all the parameters updated only after every reboot of the board? Is there an efficient way to reboot the board? I am doing this by clicking “disconnect” and then unplugging the USB cable. APM planner then tells me it has lost connection and does not want to seem to reconnect until I quit and relaunch the program.

I re-calibrated the accelerometer and the compass heading is now accurate based on the GPS/compass board orientation, as well as correct inclination/declination based on craft orientation.

I may try to maiden again this weekend, and I’m hoping it will take off and not flip/crack propellers.

You said "It seems the APM is using the internal compass and not the external compass."
Have you not disabled the APM2.5 internal compass? If you are using an external compass you need to disable the internal compass.

I think I’ve solved my issue.

The one issue I have with OpenSource academic/volunteer-based development of DIY, non-commercial products is lack of documentation. Sometimes finding out how to do something, or asking the right question, is a real road block. In this case, it was a setting in the advanced parameters.

I’m excited to get flying, but I went to ~70% throttle, and my craft did not lift off. I considered it too risky to try to maiden her if I need ~80%+ throttle for hover. It is a Turing Talon tricopter with three 620KV motors, three 20A Afro Slim ESC (really 30A with reduced cooling ability & downrated specs), 12x4.5 props, 5000mAH battery, and a simple APM 2.5 FC. Other than that just wires. I don’t have a scale to weight it, but I hadn’t even loaded up the GPS, video TX, camera or gimbal yet. I used ecalc and it suggested I move to 15 x 5.5 props if my weight is too much. I’m eyeballing a set on HobbyKing, but the US warehouse is backordered. There are some CF ones too, but I’m afraid they would be too brittle in a crash, and I’m sure to have many as I learn to pilot my craft.