Motors Spinning Oddly (twitching) when throttle is engaged

I am having trouble with my motors spinning. When it is armed and throttle is on, one motor spins correctly and the others twitch like they’re not getting enough voltage. (see video).

Specs:
Arducopter v2.8
DJI motors 2212 / 920kv
30A Opto ESC’s (doesn’t need flashing)
Power Module (came with the Arducopter)
Turnigy 3A UBEC
3S 11.1V battery

It is my understanding that these ESC’s don’t require flashing. Plus this setup worked once.
I have the signal wires only in the motor ports and the voltage from the UBEC into the OUTPUT of the board. (see photo)
I took out the JP1 jumper which I think is correct when using the UBEC.

Video: https://www.dropbox.com/s/j4741n0bf8oqpkl/IMG_6958.MOV?dl=0

Do you mean they don’t need calibrating? Have you tried to do that?

FWIW: I always connect the Signal AND Ground from each ESC. If these were truly Opto ESC the signal ground would not be common with the Battery ground. I have never really seen a true Opto ESC, just a bunch of marketing hype for an ESC with no BEC.

Everything I read out there says not to calibrate these Opto’s. I have an exterior BEC… I can try putting the grounds of the ESC’s into the OUTPUT of the board. I’m also wondering if I should replace the JP1 Jumper

I always have the signal and ground from the ESC connected to the output ports.
What ESC are you using?
Have you looked here?
http://ardupilot.org/copter/docs/common-apm25-and-26-overview.html#common-apm25-and-26-overview