Motors slow down and stop when idling


Last night I flashed the firmware on the Pixhawk of my X8 to the latest ArduCopter firmware using Mission Planner. (Side note: I previously had the PX4 flight stack flashed on it because I wanted to do some flight testing with the PX4FLOW optical flow sensor, which the ArduCopter firmware does not currently support.) I ran through all the calibrations of the hardware (magnetometers, accelerometers, gyros, RC transmitter) and then I calibrated the ESCs as well using this wiki page:

I then unplugged the battery, plugged it back in, and armed the copter (without props on). The motors ran at idle speed for about 10 seconds before ALL of them slowed down, stopped spinning and started to click. There was also a faint burning smell (not sure from where). I immediately disarmed the copter and unplugged the battery.

Is it safe to assume that all of the ESCs are damaged? I tried recalibrating them and the same result happened (idle for about 10s and then motors stopped). If not the ESCs, what might be the problem? It seems a little odd that all of the motors stopped.

Thanks for the help!



The problem still persists. I’ve tried running through the entire calibration process again, flashing an older version of the firmware, and switching batteries. I’ve read through the forums and no one seems to be having a similar issue. The interesting thing is that I can still throttle up and have all the motors spin properly (or so I think). A friend of mine believes it’s a pixhawk problem so I may crosspost to that board. It may also be a battery issue. I’m not sure though. Here are two videos that explain what is happening.

Shows the props slowing down and stopping completely: … 1.mp4?dl=0

Shows the ability to throttle up even though the motors cannot idle: … 2.mp4?dl=0

Also attached is a dataflash log.

Any help is appreciated, thanks!!


Update 2:

The problem has been fixed!


Connect copter to Mission Planner
Go to Initial Setup > Mandatory Hardware > Frame Type
Under Default Settings, select 3DR_X8_RTF.param and load it to the board

Thank you to Francisco @ 3DR Tech Support