Motors Not getting armed - IRIS+

I did my first flight with IRIS+ a few days ago. It went perfectly fine but in the second flight the motors didnt arm after pulling the throttle stick down right.

I followed the troubleshooting guide and found that motors got armed if I skip the RC pre-arming check. I opened the top shell of the IRIS+ (as suggested in the trouble shooting guide) , did the binding of the receiver with the transmitter, but the behavior is still the same. Also No message is displayed on the mission planner screen as to what might be wrong.

Please suggest as to what might be wrong and how can I check the same

I was having the same issue arming with my new IRIS+
The bottom-right throttle sequence wouldn’t arm the motors, but the arm button on Droid Planner would.

I tried calibrating the transmitter using Mission Planner (Calibrate radio control) and it seemed to fix the problem for my one last flight.

Thanks Radbert
I calibrated the tx using mission planner. I had a normal flight with all the arming checks enabled. But I again faced problems in successive flights
In my second flight propellers started spinning as soon as I pressed the safety button (I had not done the throttle stick down right step to arm the motors till then)
I re calibrated my radio using mission planner after this but in the third flight although previous behavior did not repeat and everything was fine till the motors were armed and propellers started spinning but after that even as I pushed the throttle stick to maximum, IRIS+ did not gain any altitude and I barely managed to avoid a crash.

Is there some issue with the transmitter stick or setting or something related to software (Mission planner) ?

Looking forward to your response

Did you go back into mission planner and check that all controls are still working correctly.
It could be that there is something wrong with the pixhawk controller.
Can you get the log off the copter and post the bin file. This will tell us what the transmitter was doing and what the motors did in response to that.
I have never seen where the motors spin up as soon as you push the red button.

One other thing to check is the controller itself.
Take a look at the display upon turning it on. Make sure that it showing both sticks in the centered position. The left (throttle) stick should be all the way down and little indicator should show it to be down and centered.
The right stick should be dead center.

If you need to correct either stick, hold down the + button which will bring up RADIO SETUP then press the + button again to go into the CALIBRATION page. Follow the instructions and you will be able to correct any issues with the sticks.


Thanks for your responses

I am attaching the telemetry log corresponding to the two missions. I will post the .bin file asap. Also can this be any issue with the mission planner because i did not update it although it showed an available update. My current mission planner version is 1.3.10 build 1.1.5369.11976.
Also the problem is when the propellers started spinning right after the safety button iris+ did not respond to anything not even putting ch7 (land) to on or disarming the motors.
All during this mission planner did not display any message/warning about tx or controller so connectivity was very much there.
I am getting a little lost on this.
Also I was planning to try a mission in auto mode which I haven’t till now. Can you suggest any extra checks to look out for to avoid any unexpected behavior or crash

IRIS+ FS-TH9X transmitter doesnt give me a failsafe setting menu. As a result when I try to calibrate failsafe in iris+ the throttle stays at the previous known value even when transmitter is switched off. As a result failsafe is not triggered.

My iris+ is taking flight normally now. It turns out that one of the motors was not spinning at the same rate as other three. I recalibrated everything (compass, acclerometer and ESC also ) and now it is working fine.

But I still havent been able to find the failsafe setting in the transmitter of iris+