Motors go weird when armed

I am working on a video to demonstrate my problem here. Haven’t finished it yet, but thought i would get the conversation started. I have a custom Tarot 650 drone i am building. Using Cube orange, latest firmware. 4.15 i believe. The whole thing works, and i have ‘everything’ on this machine. Optical flow, Here3 GPS. Airflow sensor, (I know a waste), another FrSky GPS. 3 Axis Gimbal. All works.

The problem is i can run a motor test at 95% and the motors run smooth a silk, and whine like nobodies business. However when i go to Arm, things go haywire. The motors are jumpy and sputtery, for lack of a better term. They stall, they stutter, at times they stop completely. Makes no sense, i can run them at 95% in the motor test for 30 seconds time and time again, and no issues, they run beautifully. What gives. Trying to avoid a complete reset of the FC cause i had a lot of setup to do to get the other components working.

I have it set to dshot600. I am using a luminar 4 in one 65amp ESC. They are connected to SERVO outputs 9-12, was told i had to use these for dshot to work, is this still true? Havent tried going back to 1-4 yet. I have never been able to get blheli passthrough to work correctly, and bricked a couple ESC trying, dont know whats up there. One issue that may be pertinent, is i have not got the telemetry from the ESC’s to work back to the FC yet, could this be my issue? Any help in this regard would be helpful as well.

Ignore it. You can NOT test a closed loop control system in an open loop manner. The controllers will only work if the copter is really flying.

Just follow the instructions Tuning Process Instructions — Copter documentation and fly it.

Your saying throw some props on it an go for it? I guess i need to revisit that article. I did use it initially when setting up, but the crazy vibration, and intermittent motor function, scared me.

Thanks for the reply, let me work through that again and i’ll update post.

Everything else has worked great, so i figure i am just missing something silly.

It makes perfect sense. Perform all of the Mandatory Calibrations and the Initial Tuning parameters and fly it.

Well to give more of the story, i did do all of this a couple months ago, and the first battery worked fine, low flying, 1-2 meters, kept it close. pure test flight. all was well, minus some fairly bad vibration on one of the motors. Flight controller calculated a hover value fine. Figured i would go for some new props, bought a new set of props, balanced them, put them on, and now i have this problem. So it was fairly random how the issue crept up. there was a firmware update or 2 that happened in there. I will work back through the setup, and post back.

Do not “work back”! Do not downgrade. Too many people downgrade, just to latter find out that it was an hardware issue and they just waisted their time.

Just use the latest FW, and follow the wiki instructions.

Absolutely, thanks for the warning. This was my intent, work ‘back through’ the setup and calibration process, on the latest firmware. Just found out i have to travel for a few days for work, so wont be back here for a few days. Thanks for all your responses.

Here is a link to a video showing my issue. I can’t really ‘just fly it’ when its doing this. It seems like its something in the flight controller, If i switch the other motor’s to the same channel, they behave the same as the one in the video.


Can you post a dataflash log ?

Edit : Did you calibrate esc endpoints?

I see today’s beta has some work done on dshot init, maybe worth a try.

i’ll have to work on the log’s in a couple days. I have tried to calibrate the esc’s several times. However with the esc’s connected to servo outs 9-12 it doesn’t run the calibration. My understanding is i need my esc’s connected to these ports in order for dshot to work. So basically no i have never got a esc’s calibration to run while plugged in as shown, and with dshot enabled.

Thanks i’ll try that next chance i get.

During motor tests i have ramped them all up to 95% individually with no issues. They all run just fine during all testing runs, but as soon as i arm that one motor stops. Channel 10 from the flight controller, if that matters.

Ignore it. You can NOT test a closed loop control system in an open loop manner. The controllers will only work if the copter is really flying.

I know you have said this before, but it will not fly. Look at the video. One motor always shuts off, no way it can fly.

He could be right, maybe the loop is shutting off one motor because not being airborne the copter doesn’t react to loop corrections.
I must admit is a bit weird tough, on mine if i arm it stays there spinning all 4 motors at minimum untill it disarm all of the motors if i don’t take off.

Is the copter strapped to something so that it can not move?
Are you seeing the issue when arming, while the throttle is idle? Or are you throttling up?

If you watched the video you already know the answers.

Thanks for all your help. I haven’t had a lot of time to work on this, but will this weekend. However i did find something, that may be related. When i went for the first flight, i did all the calibrations, all successful. The other day i went to redo them all, and the 6 axis accell cal fails immediately. Probably need to look at that first.

It will not fly, start at idle, arm, stay at idle the motors ‘idle’ for the 5 seconds as appropriate, give it any throttle and motor number 2, connected to port 10 on the FC, stops. No chance to even give it a bump and get it in the air at all.

Do you folks see any value in just factory resetting the flight controller? Is this even possible? Default all settings? I haven’t actually looked into this yet because i have been trying to avoid it, but maybe starting over is the answer?

Your IDLE looks and feels too slow. I guess you have a desync because of it. But without ESC telemetry there is no way to tell.