Motors don’t spin up beyond a gentle idle

So this week I started moving all my drones to 4.15. Argh what a journey it’s been.
Anyway most are done but this one is giving me grief.
I can take it to the field and it arms but the motors don’t spin up beyond
a gentle idle. This machine had been flying just fine before the upgrade and I have had to start from scratch to get 4.15 installed …on every machine.
Anyway I didn’t recalibrate the ESC thinking that they already where calibrated from before… but I will do it again.
In the mean time any thoughts would be appreciated.

@xfacta Hey Shawn any thoughts. I must be missing something.

Hey @rickyg32

Just an observation, but when I calibrate the sticks from my radios, the RC3_TRIM is equal RC3_MIN, but in your case the trim for this channel is the mid-stick value. Be sure that you are holding your throttle down during radio calibration.
But for me your problem seems to be hardware-related… because when you put your throttle stick up in stabilize, the FC sends high values to the ESCs (RCOU message). Double check your wiring and your power system.
Your ESCs are normal ones or Dshot tecnology? Because your MOT_PWM_TYPE is set to 4, but for regular ESCs you should set to zero.

Hi Bruno.
yes these are Dshot capable ESC.s Whats odd is that they all worked fine in the fall.
I then did some hardware fixes…not the the motors just some frame stiffening. I then went to do the upgrade and things went bad for me.
Can you elaborate on the ESC RCOU messages a bit more. I had noticed the PWM had gone high yet the motors spun slow. Makes me think there is something wrong there. But I am not sure what.

The RCOU message at the logs indicate the ammount of PWM your FC is applying to your ESCs (motors 1 to 4).
In this case, the log shows that your FC is sending pretty high PWM values to the ESCs, that’s why I told you about some possible hardware fault.
But anyway it could be a good practice to recalibrate your ESCs.

Hey Bruno.
Thank you. I suspected thats where you where going. I have done the calibration again but no change. Tomorrow I am going to see if somehow I introduced a wiring issue. I will also have a look at the BLHELI32 config to see if there is something odd there.

Thank you for your thoughts.

1 Like

Do the motors run proportional to throttle % in Motor Test?

Good question Dave.
I will test that as well tomorrow. It’s just weird. It started when I went to 4.15. Not a problem before that.

Also, you may as well use the Bdshot version of firmware while you are upgrading. It’s a better RPM reference for the Dynamic Notch filter than ESC telemetry RPM. But I suppose you would want to troubleshoot this issue 1st.

I wonder if the BLHELI settings are gone from in the ESCs and you need to set Low RPM Power Protect again???
Maybe try MOT_PWM_TYPE 5:DShot300 as I’ve noticed a couple of BLHELI ESCs dont like that DSHOT150 - I assume the quad-racer people assume no one would ever want to use a slow setting like that.

1 Like

good morning all.
Hey Shawn. Hope your well.
So this morning I did an ESC calibration using Dshot 150…I had tried this yesterday and I could not get a good calibration. It was a pain. I then did Dshot 300 and that took.
I then accessed the ESC direct using the Blheli32 interface and found much to my surprise Low RPM Power Protect was turned on. I am pretty sure it should be off. So I set it to off. Checked the remaining settings and then went to go out to test it and it’s raining. So as soon as I get a clear patch I will see if that resolves it. If so then I have a Hexa that is doing the same thing. Also new to 4.15. Will see if the problem is the same.

Calibration is not required with Dshot protocol. It will be the Low RPM Power Protect.

With regards to which Dshot protocol to run there are several variables there having to do with timing and the combination of FC and ESC. Some configurations won’t run Dshot150 for example but Dshot600 works fine. There are additional parameters in 4.2 to play around with. Want to see how complicated it can get? Check out this thread.Start at the end.


The dreaded Design Of Experiments I used to despise when I was a Test Engineer :slight_smile:

Hey Dave.
Good morning. Yes I am aware the calibration isn’t needed. But I did need to set it to Dshot to 300 as the 150 just would not take. AS for the Low RPM power protect. Puzzled why it’s on. I have a screen grab showing the previous config and it’s turned off…Anyway as soon as the rain settles down I will give it a test.

OK. You said “did an ESC calibration with Dshot150” so was confused about that. Carry on :+1:

1 Like

Hey Dave.
So I set it to Dshot 150 and pressed the button and then rebooted it. As the instructions in Mission planner state. Not sure thats calibration or something else. Anyway did it for the Dshot 300 as well. I also confirmed the pwm values for min mid and max. They where off slightly so I corrected them and then wrote the params back.
I was able to arm it and spin it up. So if the weather works in my favor I will get it to the field. I will then have a look at my hexa which has the same issue. Just still don’t get why it changed that one value. Very strange.

That is strange. Even if you updated the BLHeli_32 firmware it keeps the configuration.

Ya I know really odd. I kept a screen grab of the config for the esc and so was able to look back at it. For sure it changed.
The hexa I have that has the same issue. I am going to check it as well. Be odd if the upgrade somehow blows out that setting.