Motor speeds keep increasing

I have a hexarotor(Tarot X6) with a pixhawk FC. In my first flight in stabilize mode and had the following issues

  1. When the motors are armed and while the throttle is kept constant(drone still on the ground) the motor speeds keep increasing. When I checked the servo output from the mission planner, the pwm values for some motors(Not all) keeps gradually increasing.

  2. While flying, it takes some time for the drone to respond to the transmitter. Is this a radio problem or a problem with my esc

  3. Some motors spin faster than other motors while on the ground

What you describe is normal with the vehicle stationary on the ground. For point 2 more detail or a flight log is required but this may be normal also depending on your thrust/weight.

Thank you for your reply. What might be the reason for the response delay between the drone and the transmitter

We need much more information, like a complete parts list including motor brand and Kv rating, prop size, battery capacity and cell count, and total aircraft weight WITH THE BATTERY INSTALLED.

We also need to know what radio and receiver you are using.

I am using the tarot x6 frame. The motors are tarot 5008/340KV and the esc are hobbywing xrotor 40A opto esc. Using a 22000maH LiHv 6s battery. Total aircraft weight is about 12Kg. Transmitter is RadioLink AT9S and the receiver is RD9S. Can the response delay be a esc calibration issue

As I slowly increase throttle the drone leans to one side. Is this normal. How do I get a vertical liftoff like the DJI drones. Also in Stabilise mode, after I take off when i keep the throttle constant the drone keeps climbing up without hovering. Is this normal

It is an absolute must that you do an ESC calibration.

I have this exact frame and motor combination.

Yes… if you are in stabilize mode there is no ‘holding a particular altitude’. So it will climb or descend with the throttle, but not stick to a particular altitude’ That’s what althold mode is for.

The easiest way to take off like the DJI controller does, is to put the flight mode in althold while on the ground. Then arm the craft and raise the throttle. After you have gotten past the midpoint the craft should start to raise off the ground very smoothly. Once you get to the altitude you desire move the throttle to the midpoint.

Thank you for the reply. So re-calibrating the ESC would solve the latency issue?.
I tested Alt Hold mode with not propellers. After arming I kept increasing the throttle slowly to check the speed increase of the motors. The speed didn’t change until I reached about 50% throttle. At 50% the speed increased drastically. If the propellers were on wouldn’t the drone just take off suddenly

The very first thing I would do is re-calibrate the accelerometers. To prepare for this you need to get the aircraft PERFECTLY LEVEL.

To do this I put a small round spirit level on the Pixhawk and I use playing cards to shim the landing gear until the bubble is dead center. At this point I connect the Pixhawk to Mission Planner via USB and open the accelerometer calibration page. Before you start the calibration verify the Pixhawk is level. Shim the landing gear as necessary and start the calibration.

With the accelerometer calibration completed the next step is to run the radio’s internal stick/switch/pot calibration and then verify that all endpoint/subrtim/trim settings are at the factory defaults. When that is competed run the Radio Calibration in Mission Planner to calibrate the radio to Pixhawk.

With these calibrations completed its time to fly so we can run Auto Trim. Install the battery and verify the aircraft is statically balanced in both Roll and Pitch.

During the Auto Trim procedure YOU MUST FLY/HOVER THE AIRCRAFT. You cannot rely on AltHold or Stabilize. Stabilize should still be active, but Stabilize does not counter random drift in altitude or position. That is your job.

Once you have saved the trims we are going to “teach” Pixhawk where hover throttle is, so take off again and establish a hover out of ground effect and then switch to AltHold.

Things can get a little dicey here, so pay attention and be ready to switch back to Stabilize. The basic idea is that we want to fly around in AltHold and let Pixhawk learn where hover throttle is. If you do this right the net result is you can put the aircraft into a hover, switch to AltHold, and then switch back to Stabilize and the aircraft will not move in altitude. Another benefit when the aircraft is in a hover the throttle will be at Mid-Stick.

BTW, I read you post about testing AltHold with no props on. To be frank, that was a complete and utter waste of time.

When you use the radio to arm the motors, the PID controllers are active and when you raise the throttle the PID controllers are expecting the aircraft to be in flight when it actually isn’t. As a consequence the PID controllers get “stupid” and make the motors do strange and unpredictable things.

The only time bench testing motors with the props off is valid is when you run Motor Test under Optional Hardware.

And finally, post some data flash logs so we can see what is going on…

I agree with the ESC calibration, but I never take off in AltHold.

The fact of the matter is a new pilot flying a “new” Pixhawk that has not learned where hover throttle is will be in for a BIG surprise.

Where hover throttle is depends on the power system (battery, props, and motors) and the aircraft Take Off Weight (TOW), and there is no way of knowing that for certain until the aircraft is actually hovering, and quite honestly, taking off in AltHold will mask that, BIG TIME. BTDT.

This leads to another problem in that if “we” do not know where hover throttle is, and “we” switch from AltHold to Stabilize, we have no idea what the aircraft is going to do. BTDT too…

For this pilot, the safest thing he can do is take off in Stabilize, establish a hover and then switch to AltHold and let Pixhawk learn where hover throttle is.

As for taking off “like DJI does,” ALL of my aircraft do that because all of my aircraft are setup properly and I am in control.

My recommendation for talking off in althold was post autotune and tuning, once everything has been ‘set’. And not for an untuned craft

Arducopters Loiter mode, and to a degree AltHold, is very much “like DJI” you just don’t realize it. Consider than when armed a DJI crafts props will slowly spin and the controllers throttle is centered from spring loading. Center throllte is the hover position.This is the same with an Arducopter craft with a MOT_SPIN_ARM setting and throttle at center position. Of course all this is true after properly configuring and calibrating the craft as has been noted.

Any motor test* with the vehicle fixed with or w/o props is meaningless as there is no feedback from the sensors (accelerometers, gyros, etc.) for proper loop control.
*Mission Planners Motor Test feature (and motor test in BLHeliSuite) is an exception as it’s direct control of the motors.

1 Like

Have you performed the initial settings per this page?

https://ardupilot.org/copter/docs/tuning-process-instructions.html

This should be done before the craft is even put in the air