Motor release without radio in auto mode

Hello ,
I want to know if it’s possible to release motor in auto mode without Radio (motor interlock chanel ) only with mission planner and telemetry radio (, i use 4.1.1 Heli with external governor .(H_RSC_Mode = 2 )

Send MISSION_START from the drop-down menu.

@Mustafa_Gokce you have actually done this for a heli and it worked?

@Tarek-H I have connected a USB controller to mission planner like the one you would use with realflight and was able to control motor interlock that way. But I would only use it for motor interlock. Do not try to fly the aircraft from that controller. There is another way using mavlink commands in mission planner but I have not tried this. @tridge talks about this in a video in the wiki for continue after land. Copter 4.1 now gives an option for unknown mission items. With the unknown mission item you can program it to use any of the RC options like arm/disarm and motor interlock. He talks about it roughly 6 min and 30 seconds into the video. So that might be a way to do this. Just remember you will have to disable motor interlock first before you can arm. Then you will enable it after you arm. Let me know if this method works.

No, I did not but I am always starting the AUTO mission in copters with this command without the presence of a radio transmitter.

@Mustafa_Gokce multicopters are a little different than helicopters in the requirements to start the motor and get the rotors turning. The Motor interlock features is forced on the helicopters where it is a choice for multicopter but defaults to not having to use motor interlock. Thus you can just arm, hit auto and start the mission for multicopters. That’s not possible for heli’s. You have the step of enabling motor interlock.

1 Like

@Mustafa_Gokce i tested the Mission start , doesn’t work ,sure it work for Multicopter but in Heli it is different .
@bnsgeyer i check the Unknow Mission , just i need to specify Command ID which corresponds to motor interlock release , there is not a lot documentation about this , i will search video of @tridge and i can see the code also it can help me find a solution,i will let you know when this method work .


Here is a link to the continue after land wiki that has the video. Sorry I didn’t include it in the original post.

Hello @bnsgeyer
I did some ground tests without flying to understand the working mechanism and see if there is any risk, it seems to work, I did Unknow Mission ID 218, 32 (motor interlock) state 2 (high ) before the takeoff, and the motors starts even if the radio is ON and the interlock motor channel is off, it save the motor state , if we land and disarm the motor interlock state remains activated and saved,be careful if we arm after that in loiter mode even the radio motor interlock channel is off, the motors starts , that’s why it is necessary to enable and disabled the interlock motor by the radio channel after landing to erase the state activated by the auto mode , and in addition we can stop the motor in flight with the radio channel .

There is a small problem that I have to solve is that I put a delay before takeoff, the idea is to have like a 15 second delay for the motors to reaches the speed and stabilizes , but it seems that even with motor interlock released and the delay , it is waiting for the takeoff cmd to start motor , after the takeoff command, there is a few seconds waiting before angle of incidence starts to increase, but it is not precise.

@Tarek-H Make sure your H_RSC_RUNUP_TIME is set properly. It has to be set to allow enough time for the ESC to get the motor to the operational rotor speed. There is a bug currently for continue after land in an auto mission. The fix to that problem will come out in 4.1.3 (about 3 weeks from now). Here is the PR which describes the bug. If you plan to use this before the fix comes out, let me know and I can tell you how to set the RUNUP TIME to allow enough time for the rotor to spool up before takeoff.

I think this is a bug. the way it works now is that once the aircraft disarms it reverts back to the pilot switch. This sounds like it is a safety concern. would you care to post an issue on github or would you like me to.


I use external governor instead of internal ,esc programed for 12s Run Up .
About H_RSC_RUNUP_TIME , I thought it is used only in the internal governor case ! so this parameter work for external governor ! i will check it ! only there is a bug in case to continue mission after landing ,I am interested in knowing how to solve the problem.

About Auto motor interlock bug ,it’s not a big problem ,i think we can add Unknow mission motor interlock disable after Landing ,otherwise we need to add some conditions in the code ,it’s interesting to see another person test to confirm this bug,i will try to post issue soon in github.

I tried this in SITL and it won’t let me arm after it completes the mission and disarms because the interlock is enabled. I don’t know how you are able to arm in loiter if the interlock is enabled. You should be forced to cycle the interlock switch on your transmitter (enabled then disabled) to arm again. Don’t write the issue in github. Send me a log if you have one where this issue occurred.


No. The H_RSC_RUNUP_TIME is used in all RSC modes because it tells the autopilot when the spool up is complete. The user must set this correctly so regardless of what method is used to control rotor speed, the autopilot knows how much time is needed to spool up the rotor before initiating takeoff. For external governors, it is important that H_RSC_RAMP_TIME is set to 1 second so that the external governor immediately starts it’s spool up sequence and completes before the runup timer completes.

Here is my write up to the community on this bug. Set the H_RSC_CRITICAL to 50% and then set the H_RSC_RUNUP_TIME to twice the time it takes for the external governor to get the rotor to the set speed. This will keep the aircraft from prematurely trying to takeoff. The fix to this issue will be released with Copter 4.1.3.

Hello ,just give feedback , i do tests last week the auto mission in v4.1.1v , with Unknow Mission ID 218, 32 (motor interlock), and adjust H_RSC_RUNUP_TIME parameter , it work great ,I arm in Loiter mode with Radio ON (motor interlock switch low ) and when switch to Auto mode ,motors starts and takeoff .
I was wondering what can happen if we lost radio signal in auto mission and then the signal regained , will the state of the interlock motor be affected by the new state ( low state switch on the radio), I did some tests on the ground ,i turn off the radio then turn on to see if the motors stops, in my case it didn’t stops,good news I continue to do tests to remove all doubt.

I use now 4.1.1 , if i go to 4.1.3 or 4.1.4 , the H_RSC_RUNUP_TIME bug is solved now ?

Yes, the fix went into 4.1.3. The flight controller will now wait the full amount of time given by the H_RSC_RUNUP_TIME parameter before it declares ground idle. Therefore for subsequent spool ups in an auto mission, it will use the full amount of time specified by the H_RSC_RUNUP_TIME.