Motor not spinning

Thanks for the new Pixhawk controller. Guess the old one will be put into one of my cars, or maybe into one of the farm machines.
It has been mounted and set up.

However i run into an issue before i replaced the controller. One motor would not spin in preflight mode, and the iris is not behaving very stable in flight to be modest.

I have screenshot from the last bench test, showing that one motor does no get the same modulation as the other 3 motors. (To large for the forum to upload)
The iris is mounted on flat large table during the test.

Any idea on how to proceed the failures investigation?

I have dismounted the motor and there is at least no debris inside it.
The motor spins when it is powered up, but it does not run as smooth as the others.

FYI: i have not adjusted any setting in the controller others than doing calibration.

Just let me know if more details, or calibration files etc.

Please attach a log file to help with fault finding.

I have attached the Log file, not sure if this is helpful.
Let me know if you want the dataflashLogs, because then i have to redo the recording.

That’s the APM planner log, not a dataflash or tlog. Best to post a dataflash log.

here is a small bench test without propellers installed

Did you calibrate your ESC?

I did that now resulting in a very heavy smoke coming from the ESC.
One of the motors where still not spinning at idle speed and gave a very intermitted sound when trying to speed up.
I will take it apart and inspect the damage :neutral_face:
After inspection i found that one of the wires had an been melted in the soldering on the ESC and came in contact with other soldering.
Think i need a new ESC before i can continue as it look like the ESC is damaged also.
Now the question that arrises: where can i get a new one, as they are not listed on the 3DR store yet?