Motor failure and unstable flight. Help understanding .BIN

Hello All, I am having an issue with stability and random movements. I do not understand what I am looking at in the logs. Does anyone have the time to teach me what the log is saying. Thank you for your help

If you remove the access requirement in the link!

sorry. I am new

Let’s start with what won’t work.
You won’t get Dshot on the Main Outputs of a Pixhawk. You have to use the Aux outputs and re-assign the motors accordingly starting with SERVO9_FUNCTION (Aux 1).
Dshot1200 is not reliable, set it to Dshot600.
Set this back to default (0) SERVO_BLH_OTYPE
Set this to 1 or 2 depending on whether you have BLHeli32 or BLHeli_S ESC’s

The motor outputs are oscillating badly but fix the above stuff 1st and then make a simple hover flight in AltHold for a minute or so. You will need to configure the Dynamic Notch Filter so set INS_LOG_BAT_MASK to (1) before doing the flight. Then post that log.

Describe the components on this craft and the take-off-weight (with battery).

1 Like

That was a crazy flight. I made the changes and it flew but was surging like mad. I had to switch to stable because it was not controllable. The quad is a 500 frame, Pixhawk 2.4.8, SunnySky 2212-980, 3S, 35A BLheli32 ESC, dual gps, 10" props, 1495g with battery, 5500mah…

Thank you for your help, really appreciated!!

i forgot to change the ins_log_bat_mask to 1.

I’m thinking now that you have me going in the right direction I should just start fresh. Flash the firmware and start over?

I just saw you are from Michigan also. Cool. Small world. I’m in the Grand Rapids area.

I was going to suggest that because that’s a standard kit that should fly on default+ Initial Setup parameters. Maybe not well but not like this:

You should connect ESC telemetry also as it will be helpful with the Notch filter.

Yes, in the Ann Arbor area!

Just an update. I did a pass through connection to blheli suite and found that the ESC were out of sync from the master. I flashed and reset all the ESC and am setting them up again. I hope this was my problem. :crossed_fingers:

This may have no impact depending on what was out of sync.

Well I thought I would try you before making a new post. My pixhawk just died. I do not know why. Possibly a shorted safety switch. I have tried reflashing firmware. Holding a new switch while booting. No luck. It can not write to the FC. Any ideas?

Try flashing using QGroundControl. Selecting Arducopter chibios and the board. I don’t use Safety Switches.

This actually got me somewhere. So now my board beeps and the RGB LED lights but when I try to calibrate the radio it will not let me. From reading it seems like the I/O controls the radio outputs? Which is on a different FMU? When I go back to mission planner and flash the firmware the board goes back to being dead. Thoughts? Thanks again for your help

The I/O processor produces the Main Motor outputs.

That seems to be my problem. I tried resetting the IO but no go. Is it possible to test the IO portion?

Would that make sense because of all the oscillation you pointed out?

Not that I know of. For ~$100 you could replace it with a Matek H743-Wing V3 with the latest and greatest hardware :slight_smile:

Hard to say as that oscillation signature is common with poorly tuned craft. We see it several times a week.

Possibly a GPS issue lurking as well…your original log shows numerous variations in the number of sats locked, along with big hdop swings…I mention this as I have a poor GNSS sky, and ‘GPS glitches’ have masked other issues. I had a partial flyaway when switching modes to Loiter from Althold. Quad shot off at 90 degrees from the course
and shot up, saved it with Stability mode & landed…just a FYI… GL!!

1 Like

Looks like I am getting a new FC. The board you recommended, will that be good for a 500 class camera drone? It looks nice. So it is a good replacement for a PX4? I am not going to waste anymore time on this pixhawk. Thanks again!