Motor armed but not spinning __trad heli with Pixhack

I managed to get the motor on my Align Trex 450 running during initial bench testing , but all of a sudden after a couple of days, without changing any parameter, the motor does not spin after it is armed as shown in MP.
• PWM of Ch8 (controlling rotor rpm) has been set in Tx to enable arming of motor.
• when disarmed, “STATUS” tab in MP shows “Ch8 in” PWM increases from 1029 as Ch 8 is increased from minimum.
• When armed, “STATUS” tab shows “Ch8 out” PWM increases from 1025 as Ch8 is advanced from minimum, to maximum of 1937 when Ch8 is at maximum, but motor not spinning.
• After motor is armed, if Ch 8 PWM is not increased and left at minimum, motor will disarm in 10 seconds. But if Ch 8 PWM is increased above minimum after arming, motor will not disarm in 10 seconds, meaning Pixhack is normal without problem on the arming part.
• ESC and motor are isolated, connected to another receiver, tested and found to be working.
• Pixhack 2.8.4, Copter 3.5.5, Redcon 7Ch Rx with PPM output, PPM encoder, genuine Align Trex 450 flybar with stock ESC.

I have another setup of Trex 450 FBL, APM2.6 , Orange 10 CH Rx. This setup has no problem arming and motor spinning.

This is very weird. Pls help.

You probably don’t have a log since can’t get it to fly. But the parameter file from the controller might help to see if there’s a configuration problem.

Hi Chris,

Thank you for your reply. You are right, I don’t have a log even though I
can arm the motor.

Attached is the full parameter. If possible, pls review it to see if you
can get some hint on this weird problem.

Thank you in advance for your help.


Heli motor armed but not spinning__July 2018.param (13.5 KB)

Not related to the problem, but you have a critical issue if you ever did get this helicopter to fire up and try to fly it. It is a flybar. Please set all the P,I,D values in these params to zero and set the VFF values to at least .15 and make sure that at .15 you have full servo travel when moving the sticks

Right here is the issue with why your ESC won’t initialize. It looks like your RC likes to calibrate from ~1126 to ~1970 pwm. How did the min values on these get set to what they are? Is this what it actually got calibrated at?



And your SERVO8 min/max should be 1000 and 2000. How did these values get entered this way? This is not going to let your ESC initialize.


I would suggest setting the SERVO8 min/max properly, recalibrate the RC and try it again.

Thank you for your help, Chris.

In fact, last year Nov 25, you did remind me to set all the PID to zero,
except VFF, for flybar. I did not attend to this yet as I focus on getting
the motor spin.

I did set the RC_8 max/min to 2000/1000 in Full parameter list, and did RC
calibration (travel of Ch 8 at 100%) again. Armed the motor again, but
motor still not spinning. After checking the parameter, found the values
of RC_8 max/min return to 1939/1106, as shown in the attached param file. I
don’t know why. I did this twice with same result.

I thought as long as RC_8 min is above 1000, and RC_8 max is below 2000,
the values do not matter as long as the motor can be armed.

One thing I notice is : there is no beep of cell count ( 3 in my case) when
I power up the heli. Before I draft this eamil, I powered up the ESC and
motor together with ANOTHER Rx, and I can hear the usual 3 beeps of cell
count from the ESC. The ESC on the heli is Align RCE-BL35X. Do you think
the Pixhack does not recognise the signal from this ESC , or there is
something wrong with the signal from the ESC ?

If yes, why did the motor spin during the ititial stage of bench testing,
but stop spinning all of a sudden ?

Appreciate your help again.


Motor armed but not spinning__1.param (13.5 KB)

No, SERVO8 min/max is different from RC8 min/max. Your SERVO settting looks fine now. But after calibrating the RC your RC mins are all over the board on the different channels. What sort of setup are you using in the RC? Do you have mixes turned on? Do you have the endpoints of some of the channels set differently? How is the throttle handled in your RC?

Frankie, I see that you have LOG_DISARMED turned on. Could you do the following -
Shut everything down. Power up your RC. Power up your flight controller. Arm it. Attempt to start the motor like you normally would. Disarm it, shut everything down and get the last log file off the SD card in the Pixhack and either post it here, or put it on a cloud sharing service where I can get it.


Hi Chris,

I got the log file off the SD card with only 1 KB data(name of file is LAST
LOG, a text document), which is a figure “309”. I got it after arming and
disarming. Should I turn off LOG_DISARM to get the log file ?

— I have 2 mixes :-- Aux 1 (flap switch, 3 positions) to Gear (2
positions to get 6 flight modes).
— Gear end points are set to 40% and 70% for flight mode offset.
— Aux 2 for RC_8, controlled by the rotary knob (end points 100%)
— Pitch controlled by throttle channel (Ch 3 in my Spektrum DX7s)

All these pose no problem in my other setup (Align 450 FBL, APM2.6, Plush
40A ESC).

Pls see attached the diagram of the wiring. (some of the notes in the
attachement may not be correct, pls point out any mistakes you may spot.
But the wiring diagram is current.)


Will communicate with you again tomorrow evening after test flying my Align
450 FBL /APM2.6 early tomorrow morning.


I’m sorry, when I said last log I meant the last .bin log, which should be something 309.bin

Hi Chris,

Pls find attached the last .bin file.

Thank yuo for your continued support.


00000311.BIN (612 KB)

Frankie, I’m not sure what I’m seeing here - never seen this before. But this is the graph of the RC inputs with the throttle output included

The vertical lines are where you arm the system (or attempt to) but it never arms. Now look at the values of the RC inputs before you arm.
Channel 3 is at 1013 pwm - this is collective
Channel 4 is at 1548 - this is rudder
Channel 8 is at 1108 - the is the throttle signal from the RC

Channel 8 out is flatline all the way thru - 1000 pwm, which is engine off.

When you arm:
Channel 4 goes to 1099 when it calibrated at a min of 1126. So this is whacked - you’re getting different values than what the min should go to. Further, by holding the stick down and to the right to arm the rudder should go to max of 1969 (what it was calibrated at). So I’m going to say you have Channel 4 reversed in the RC. And it will never arm that way.

Channel 3, which is your collective, should be at the min when you arm. Instead it goes to 1465. That channel calibrated min/max of 1004/1945. So once again, there’s no way this thing can arm.

Really, really, really weird:
After you release the sticks to arm, the values should be the same as before you attempt to arm. But what we get is:
Channel 3 drops to 901
Channel 4 drops to 1502 (when it was 1547 prior)
Channel 8 in drops to 932 when prior to arming attempt it was 1108.

This radio is severely got serious problems. Have you opened it up and looked in it? Did somebody dump a can of Mountain Dew in it? Does it even have a battery in it? It’s like it goes completely dead as soon as you move the left stick.

Hi Chris,

Thank you for your analysis. I need some time to digest the graph and your
comment before responding.

Meanwhile, I am attaching the log files in .bin and text format for my
other set up for your comparison :–

 Align 450 FBL, APM2.6, Plush 40A ESC, and 10 CH PWM Orange Rx (no


I have no problem with this set up except serious TBE during position hold.
The rudder channel in my DX7s is also reversed as in the problematic Align
450 flybar version. In the attached log files, after I arm the motor, I
increased CH3 (pitch) a bit to extend the period of arming by few seconds.

As the data in your graph shows the motor is never armed, how can we
explain the HUD in MP shows “ARMED” after I push the rudder stick to the
right ? I hope this comparison with the FBL version will shed some light
to solve the problem.

By the way, what tool do you use to graph those data from the log file,
somewhere in the MP ?

Best wishes


2018-06-03 15-04-45.bin (88.7 KB)

2018-06-03 15-04-45.log (201 KB)

There’s not much that can be derived from the log from the old APM. It didn’t log RC inputs, etc… There has been so many changes in the firmware since 3.2.1 that the two can’t be compared. The setup is TOTALLY different in the new firmware.

I don’t use Mission Planner at all. I am looking at the logs with APM Planner2, which has much better log analysis tools.

I don’t know why the HUD is showing armed. It does not log it as being armed - it just goes dead when you move the stick, some of the RC outputs drop to what is evidently failsafe values like the receiver/RC connection just goes dead.

It’s a pity we can’t compare. I have a Pixhawk installed on a 500 size
quad, running the most updated firmware, and using the same Tx without
problem. In future, I try to use the graphing tool in APM Planner 2 for

Regarding the issue, not only the HUD shows ARMED and DISARMED (after a
periof of inactivity), the STATUS tab of MP also shows the changing values
of Ch8 IN and OUT PWM values as the knob (CH8) is increased before and
after arming. This shows the controller is acknowledging the signal from
the Tx.

I will change another ESC to give it a try.

Will keep you posted.

With the values I see in that log it would be impossible to arm. The rudder is reversed in the radio and you can’t do that. Only the elevator (channel 2) is normally reversed in the RC. If you need to reverse the rudder (SERVO4) you do it with the SERVO4_REVERSED parameter, not in the RC.

Being the RC calibrations are all over the board, and the outputs to the flight controller are totally not normal, there is a serious problem in the RC radio. If you are using a PPM encoder it could be in the encoder too - it is the most inconsistent I think I have ever seen.

Hi Chris,

I just found out I committed a very low level mistake…the ESC
is plugged to the S bus port, an output port next to the Ch 8 OUT on
Pixhack !!!

If you have time, can you take a look at the attached .bin files which I
got after rectifying the mistake, see if the arming and Rc settings are
normal ? I don’t know why there are 2 .bin files. I have already erased
everything on the SD card before I arm the FC, only once.
Thank you.


00000001.BIN (1.9 MB)

00000002.BIN (284 KB)

Everything looks fine except for I never saw any throttle out values in those logs. But H_RSC_CRITICAL has to be set to something lower than hover throttle. CRITICAL should be set to where the heli barely flies anymore, or can’t fly.

And H_LAND_COL_MIN, based on what I see it looks like you might be running for collective range, should be set up to about 150 or so.

If you don’t have any sort of governor, it would be highly recommended to load 3.6-rc6 in it and use the new five-point throttle curve with Mode 3, instead of Mode 1 throttle. Mode 1 (RC Passthru) can be highly problematic on auto flights if you lose RC signal.

Hi Chris,

Thank you for your continued support.

I only armed and disarmed the FC once (don’t know why there are 2 .bin
files) without spinning the rotor. That is why you don’t see any throttle
out values.

My current H_RSC_CRITICAL is at 500. But I can’t find the hovering throttle
param. The closest is H_RSC_POWER_HIGH and _LOW. So I have no idea what I
should set so it is something below that. Pls advise.

Descriptions in the param H_RSC_POWER_HIGH mentions about H_RSC_PWM_MAX and
_MIN. Where can I find these 2 param ?

For H_LAND_COL_MIN, as the name implies, it is the minimum collective pitch
during landing. But how is it related to H_COL_MIN ? I presume H_COL_MIN is
the absolute minimum the collective can go, and H_LAND_COL_MIN is usually
set above this absolute minimum for landing during auto mission, am I
correct ?

I purposely set the H_COL_MIN to 1 or even 2 degrees (that’s why H_COL_MIN
of 1420 is so close to H_COL_MID of 1490) to avoid heavy impact during
landing as I am always nervous about abruptly pulling the collective stick
all the way down during initial testing. Understand the danger involved in
strong wind to bring the ship down. Other than this, what is the
disadvantage to set a positive minimum collective pitch , as I never do
flight testing in strong wind ?

I don’t use any governor, and have updated to the Beta version 3.6-rc6.,
and changed the Rotor speed control to mode 3 for Throttle curve. Is there
tutorial or background reading for how to use the Collective Control graph
in the Heli setup page ?

Last question : Both my Align 450 (flybar and FBL) have the GPS
antenna mounted
on the anti-rotation bracket, in place of the stock gyro. Does this cause
TBE due to rotation of the main blades above ?
Thank you.

OK, if your MIN is above zero pitch then leave H_LAND_COL_MIN at zero.

The throttle out is the signal that goes to the ESC on Channel 8. Fly it and see what it is. If you’re sending 1500 pwm to the ESC (50% throttle) then set CRITICAL to something below that like 300 or 400.

That heli setup page in Mission Planner is BROKEN! DON’T USE IT! It will screw up your helicopter settings beyond all recognition. I had requested some time back that that page be removed from the program but it never got done.

Please download the latest daily build for QGroundControl and use that. It has a new heli setup page in it that actually works and won’t crash your helicopter with bogus settings.

Edit: If you have even visited that heli setup page in Mission Planner with a helicopter connected to it DO NOT FLY IT until you connect it to QGroundControl and double-check all your settings. I found that heli setup page in MP will make unwanted settings to your heli just by visiting it and exiting the page - without you the user changing anything. Especially if you got Copter 3.6 loaded. I might have to pound on a few desks until that page gets removed from Mission Planner before it seriously screws up somebody’s helicopter and crashes it for them.