Mission planner terminal continuously prints data

today i flashed last APM FW revision and last mission planner version.
if i power on and go on terminal window, after pressing “reboot APM” the apm starts to print strange characters.
and i’m not able to download logs or to send any other command on terminal.

here annexed you can see the screenshot where you can read the mission planner version and the apm version.

how can you explain this?


The previous version of mission planner (1.3.9) that it was previously working, now gives the same result. This means that the problem is in the APM last firmware revision.

i flashed previous version of apm and i found that the problem is not present.
this is a screenshot:
So the problem appears as soon as i flash last fw revision of apm.


Probably not much help but i have same problem .I have checked the 3dr radio settings and they are fine, i have two sets and they have the same settings and i get the same results as yourself.
I found a post advising to change the radio mav link settings to raw data, however as they work with apm
Previous firm ware i have left them as they are. I have four copters and have only migrated one too 3.2 so far. Ime going to search other forums to see if i can find a better answer.

The CLI has been removed in the latest version of Copter on APM 2.x boards (because they’ve run out of memory), so what you’re seeing is just binary MAVlink.

At this point there should be no need for the CLI. All of it’s functions are now implimented in MAVLink, including datalog reading, so you shouldn’t have to use the terminal at all.

CLI works for me perfectly fine in 3.2 and Mission planner.
Pls ensure that you connect via USB cable, NOT through the 3DR telemetry link.

Steve, which board do you have? Pixhawk still has some CLI left, so that might explain why you can still get it.

So if I need to run a Motor Test on a Quanum Nova (APM 2.X clone) to confirm their factory wiring, how can I run that if I don’t have a working Terminal in Mission Planner or APM Planner?

I don’t have an APM handy to test myself, but can you see if the procedure on this Pixhawk page works for you?

copter.ardupilot.com/wiki/connec … s-pixhawk/

I’ve used the method described in Rob’s link on 3 different APM’s and it works perfectly once I increased the percentage up to 10%.