Mission Planner can't see ArduCopter on BeagleBone Blue

Hi everyone,

My son is building a quadcopter drone for a school project and we’ve hit a hurdle. Any help would be much appreciated, we’ve done a few things like this before but I’m on the edge of my knowledge. I hope I’ve posted this in the right place.

We followed these instructions: https://github.com/imfatant/test

Once we get ArduCopter installed, we can connect via SSH and “systemctl is-enabled arducopter” says that it is running. But Mission Planner can’t detect it via USB or over Wi-Fi. I’ve disabled the firewall on the PC.

Mission Planner’s Auto mode searches and doesn’t find it. Connecting via USB/COM fails. TCP fails, the error says “No connection could be made because the target machine actively refused it”

I’ve searched online for answers. It’s turned up a few options, such editing /etc/default/ardupilot to TELEM2="-A tcp:"

This didn’t help.

A few notes on this guide: https://github.com/imfatant/test

This exact image isn’t in the archive anymore.

We tried a few with nearby timestamps. We even tried the latest version and then manually compiling ArduPilot to get the latest version. Always the same result.

There’s lot of talk about specific real-time kernels and the need to fix bugs, not sure if that’s an issue here. Can anyone link to an exact build of Debian and ArduPilot that definitely works on the BBB? Other guides also tend to have broken links for the exact Debian image to use.

I’m also wondering if there’s a permissions issue when copying arducopter 3.6 onto the BBB using FileZilla. I tried changing its owner to root, didn’t help. I tried changing its group to root, but that change didn’t take.

Do I only need to copy arducopter from here https://github.com/imfatant/test/find/master
to here

That link also has file called am335x-boneblue.dtb, which I didn’t see earlier, does it also need to be copied across?

It’s also worth noting that we haven’t added any hardware to the BBB yet, like motors, GPS or wireless controllers. I think we should still be able to detect ArduCopter running. I’m wondering if we need to edit /etc/default/ardupilot to tell it there are no RF or GPS modules to search for.

Any suggestions would be greatly appreciated.


You need to ssh to the bbblue and launch ardupilot manually to check if it starts correctly.
There is not much support on the bbblue, but you may try the gitter channel

Thanks, what’s the command to manually start arducopter?

I think I did the right thing, this was the result:

debian@beaglebone:/usr/bin/ardupilot$ ./arducopter
“Scheduler: failed to set scheduling parameters: Operation not permitted”

so I tried this:

debian@beaglebone:/usr/bin/ardupilot$ sudo ./arducopter
RCOutputAioPRU.cpp:SIGBUS error gernerated

A search on that error turns up a few leads, I discovered some useful info on the gitter channel so I’ll dive into that and see where it gets me.