Missing MNT parameters in MissionPlanner SOLVED

In Copter 4.3 and 4.2 I have no MNT parameters. Does anyone have suggestions ?

Some flash-constrained boards have MOUNT support compiled out

Thanks for your reply. I presume by "flash constrained " you mean through new versions of Copter. It’s a Pixhawk 2.4.8 I’m using.

If you have Pixhawk1 firmware flashed, which is the correct one for that FC, the Mount parameters will be there. I guess you have fmuv2?

do you have to enable mnt before the parameters show up on mission planner?

Good point. You have to enable one parameter for the rest to show up yes. I have seen this question before and I think for the same reason. If fmuv2 is loaded on a Pixhawk you get this even if it has 2Mb flash:
Pixhawk 2.4.8’s have 2Mb flash so Pixhawk1 should be used.

Thanks for your help folks. I have not managed to get out of fmvu2 but I reverted to copter 4.02 c/w with MNT parameters. This fixed things for the meantime. My FC’s chip is a V3 chip may have 2Mb. I’ll look into it further when time permits.

Download the arducopter.apj file from here and use the load custom firmware option in Mission Planner to flash it:
Pixhawk1 Firmware

No reason to use a firmware revision that is 2 yrs old.

No joy with Pixhawk1 firmware Dave. Back to fmuv2 4.03 in meantime. Thanks

Tried copter 4.07 which also had MNT parameters. Then decided to go back to copter 4.13 and try fmuv3. This time it installed. !!! Happy Days and thanks for your interest.

The version is not 4.13. It is 4.1.3. And when 4.1.4 comes out you can and should safely update.

But when 4.2.0 comes out you need to think if and when you need to update.