Minimum flight speed 1m/s?

When using Mission Planner to plan a mission it is only possible to fly at 1m/s or faster. Is this a limitation of MP or Arducopter? Is there any reason why it’s not possible to fly slower than 1m/s. Also is there any reason why it’s not possible to define autonomous flight speed with more accuracy than integers?

1 Like

Hi @Tryggvi,

I am also interested in this issue. Could you please share any progress on this issue?

There is no such limitation.

1 Like

At the time we didn’t find any option to do it and I have not checked again. But @Dongsin_Kim you are facing this issue now and @dkemxr you are saying this is not a limitation right now?

1 Like

Right not limited to 1m/s. Try it in Mission Planner’s Simulator.

1 Like

Hi @Tryggvi and @dkemxr,

Thank you for the replies. Yes, I am facing some issues that (not an lower speed limit on Mission Planner but) I could not enter a non-integer value (< 1m/s) on Mission Planner.

Please let me explain what I am trying to do:

  1. In Mission Planner´s [PLAN] section, I would like to add a new line for the [DO_CHANGE_SPEED] command.

  2. When I put some non-integer values (I would say 0.5) on [speed m/s] section of the line, I am facing some errors as follows:

Invalid number entered; Invalid number on row 1

I don’t get that error, 0.5 is accepted and written to the Flight Controller. Tested with Arducopter current Stable and latest master.

1 Like

I guess your computer is configured to use a non-english language/locale setting? This problem awfully reminds my to my bug report from 2013. I have crashed twice due to this problem (PID params got zero) and the bug was never fixed AFAIK. I stopped using MP due to that kind of trouble.

1 Like

Hi @dkemxr and @hsteinhaus,

Thank you for your considerations and sharing your insight with me. I have just solved the problem and both of you are right. :smile:

The problem have came from the in-consistency of the keyboard layout (and also my bad). I used to an international keyboard layout (which has a “.” next to “0”). For the Mission Planner, I have used a danish keyboard (which has a “,” next to “0”).

Fig 1. International Keyboard Layout

Fig 2. Danish Keyboard Layout


Please let us see this image again. I have thought that I had typed “0.5” (but it was actually “0,5”) and it have caused the invalid number error".

Well, I still think it is a software bug in MP’s number input handling (7 years old now). I am pretty sure, that Excel or the Windows calculator behave different here and accept the comma sign as decimal separator. Fortunately, the effects are very limited when changing the WP speed, but you can also easily crash your vehicle if you edit PID coefficients while the vehicle is in the air.

1 Like