MinimOSD works but no data on screen

[attachment=0]image.jpg[/attachment]Hello. I’m using a minimOSD connected to Telem2 of a pixhawk. Everything appears to be fine and my monitor displays my live video feed with the OSD overlay. The issue I have is that the osd displays zeros on all parameters. See attachment of screen shot. Any help on this would be appreciated.
Thanks in advance.

1 Like

I have the exact same problem.

All values show zero. I have current sensor attached and mission planner shows and detects the voltage. But minimOSD is showing 0.0v. It is also flashing LOW RSSI , LOW BATTERY , NO GPS FIX.

The only thing that works is switching flight modes, minimosd shows that I am switching flight modes.

Everything else just doesn’t seem to work. :question: :exclamation:

I have also changed the parameters in mission planner that’s required for minimosd to work.

You also have to activate the OSD in Mission Planner -> Initial configuration -> Optional hardware -> OSD

Yes, I’ve tried that and still no luck. I might add, that i’m using a Mac with APM Planner V2.0.9 if that makes a difference???

If you are using are connecting the minimOSD and the telemetry radio using only 1 TELEM port with a Y cable, please establish a telemetry radio connection with APM planner and see if this is updating the telemetry data in the minimOSD.

I fixed my issue.

I connected the minimosd to telem 1, instead of telem 2.

It might have - in my version of APM-Planner for Linux, the button doesn’t do anything. I had to boot up Mission Planner in a Windows VM and use the button in there to get my OSD running.

Hmmm. Not having any success :frowning:
I’ve tried using Telem1 for the minimOSD, still the same fault. I’m not using the Y cable to the Pixhawk. 3DRadio is in Telem2 port and i’m able to communicate to it in APM planner. All data on my Mac is good: Attitude of the Quad correlates to the horizon on APM planner. Voltage, GPS fix, etc display correctly on the Mac.
I’ve tried ‘enable Telemetry’ in initial setup, OSD in both Windows and Mac versions, and still nothing :frowning:


Are you using a 4 wires cable to connect the minimOSD? … or-pixhawk

Yes, that’s the cable I’m using. Tried plugging in both Telem1 and Telem2 ports and same result. I’ve updated the minimOSD with new firmware as well as the charset, no difference. :frowning:

What is the firmware loaded into the Pixhawk?

Could you share your param file, please? to get it go to config/tuning, planner, check advanced view, click config/tuning again, go to full parameter list, click save and select a name and file location.

I am having the same problem, I have two new Pixhawks, two MinimOSD’s and they were both working before I updated to the MinimOSD extra with copter Firmware, previously I was using old firmware, (not the plus)

In Mission Planner, all data appears fine. Initially in the OSD, the labels, and icons appeared but no data like others have posted. After reading all the suggestions, I edited the Params in Mission planner for SR0 and SR1
and saw no difference, Finally I switched the telemetry port of OSD to telem1 and put the 3dr Radio n telem2
I thought this was finally solved. but then I turned on my Radio Transmtter, and the data display disappeared!

I am using a Taranis with the Exuhf pug in module, the the 8ch lite receiver and using PPM. the receiver is powered from the rc cable that also carries the PPM signal.

The the data display always drops out when I turn on the transmitter, I can turn off the transmitter and the data does not come back.

I can turn power off then back on to the Pixhawk, and the data display will always come back, as long as the transmitter is not turned on.

I notice that when I turn on the Taranis, it goes throughout the normal switch position check before beeping along with a voice welcome message “welcome to Taranis” and then enabling the RF. At the moment it beeps is when the data display disappears.
I must mention the data doesn’t totally disappear, it leaves a artifact, one icon that looks like a road sign for “curvy road ahead” and some 3 digit number, not sure what it is, That is all that is left.

Any ideas? OSD is important to me, I use mine for photography work, and need to monitor my batteries and flight time without having to take my googles off to look at the mission planner screen that is typically hard to see in the sunlight…

I finally got it working, figured out a piece at a time till it worked. first, I had to use telemetry port 1 for the OSD and telemetry port 2 for the 3DR radio. Then I had to edit the SR0 and SR1 settings to the values show above in the thread. I think at some point, it did not write those settings, the last time I tried this, I had just updated to the beta 3.2.rc9 When I clicked the write button, it acknowledged that it was written.

Then, I went into mission planner and clicked the button to tell MP that I was using an OSD. (Im not really sure this did anything at all, there is no feedback that acknowledges the button press).

However, then when I tried the odd out again, data began to show actual values instead of zeros.

Then the final piece of the puzzle solving this; once I got data showing, the data overlay display seemed to go away when I turned on my RC Transmitter… That had me puzzled for a while until I realized the radio by default was triggering the ODS to go to Panel 2, and I had nothing programed for that…

I then used the CT tool to set up panel 2 the same as panel 1, and now, everything works as it should…

1 Like

Could you please post your settings for SR0 and SR1? Thanks! I am not getting GPS fix on OSD although the pixhawk has it.

[quote=“richard_evans”]I finally got it working, figured out a piece at a time till it worked. first, I had to use telemetry port 1 for the OSD and telemetry port 2 for the 3DR radio. Then I had to edit the SR0 and SR1 settings to the values show above in the thread.

Richard…could you explain the SR0 and SR1 values? There are no values shown “in the thread”.

1 Like

I fought this same issue for days. This is how I finally got it working for my APM quad-

Use a Y cable to connect to both the Minim OSD and Telemetry radio. The OSD RX is from the APM TX splice, also 5v+ and Ground are spliced to corresponding output of APM. That’s it for the connection.

The issue I fought was the following:

  • Battery, voltage, time, altitude, etc. showed “zero” on my heads up display. APM was not sending data to OSD (or telemetry radio for that matter). The artificial horizon WAS WORKING.
  • Connecting APM to my ground station (Mission Planner or Droid Planner) would immediately cause the APM to begin sending data to OSD, and now my heads up display starts showing data normally. Disconnecting the ground station, the OSD continues to function normally. The problem with this is I don’t want to connect then disconnect my ground station every time I want to fly.

Here is how I got it to work without the need of connecting the ground station:

  • Set the parameter “TELEM_DELAY” to 10 (delay 10 seconds). This delays communication attempts between the APM and Telem radio. I think what was happening is that the radio was initiating communication with the APM before the APM was ready to receive the request. So the APM never started transmitting the data.

  • Set parameters per the following:

SERIAL1_BAUD, 57 (telemetry output at 57600)
SR1_EXT_STAT, 2 ( 2hz for waypoints, GPS raw, fence data, current waypoint, etc)
SR1_EXTRA1, 5 ( 5hz for attitude and simulation state)
SR1_EXTRA2, 2 ( 2hz for VFR_Hud data )
SR1_EXTRA3, 3 ( 3hz for AHRS, Hardware Status, Wind )
SR1_POSITION, 2 ( 2hz for location data )
SR1_RAW_SENS, 2 ( 2hz for raw imu sensor data )
SR1_RC_CHAN, 5 ( 5hz for radio input or radio output data )

I also tried to set SR0_xxx, but never got it to stick as others have also discovered. I understand that SR0 is for the USB, and SR1 is for the telemetry port on APM2. I don’t think it is necessary to modify SR0 anyway.

The above worked for me, hopefully it works for you if you are having the same problems. 10 seconds after plugging my chopter in, I have all OSD data reporting. By the way, I flashed my minimOSD with MinimOSD-Extra.

Good luck