minimOSD won't boot with KX6 camera attached

This has been driving me crazy for days now.

I have run through every parameter change, every firmware upgrade, every wiring configuration but on power up all I can get is plain video, no OSD overlay.

Today I powered up without the camera and low and behold the OSD boots up and displays it’s stuff in grand style. Plug the camera back in while powered up and I have the OSD nicely displayed over my image.

But have the camera connected on power up and the OSD will not boot.

The camera is KX-6 from RangeVideo, a 1/3 inch 470 PAL, with very nice resolution.
I tried an old KX171 and the minimOSD had no problems booting up at all.
But not the KX-6.

I tried a suggestion on the forum that the peak-peak of the video was too high and tried a resistor in series with the video line. Even adjusting the video to it’s lowest limit did not help. If there is video from this camera the OSD will not boot.

I am tearing out what little hair I have over this one, so if anyone out there has any suggestions, anything at all, I would be eternally grateful.

Did you use the CT tool to manually set the video mode to PAL, or is it in “AutoDetect” mode? It sounds like the MinimOSD is detecting the video mode incorrectly when you boot with the camera attached and is setting it to NTSC mode. In the CT tool you can select :Video Mode>Pal then “Save current tab to OSD” . This will ensure that the MinimOSD always boots in PAL video mode and doesn’t use “AutoDetect”.
Nathaniel ~KD2DEY

Thanks Nathaniel, that is one of the many software configurations I have tried and it did not work.

I even went back to it after your suggestion and tried it again just make sure I had not screwed it up the first time.

It boots up with nice clear video but no OSD.
Pull the video off and a grey screen with the OSD appears.
Plug the video back in and I get the OSD nicely laid over the video.
This is exactly the same for the 4 minimOSD’s I am working with, 2 from 3DR, 2 HK clones.

Just to further the possibilities, I have configured a board to run both ends from APM power, ie: closed the jumpers, and removed the camera 12 volts from the OSD to just a direct connection between VTx and Camera.

In this configuration the HUD cannot be made to display over video at all.
If I pull the power from the camera I get the grey screen with the HUD from the OSD, but plugging power back into the camera gives me only video with no HUD.
If I pull power from the APM and keep the camera and VTx powered up, then power up the APM I get only video, no HUD.
If I pull just the camera video line, I get the grey screen with the HUD fully working, but plugging the video line back in gives me just video.

So in this configuration I cannot get the HUD to overlay the video AT ALL.

I have 2 KX-6 cameras and both do the same thing.

So, anyone, someone, is there an answer?
Can anyone give me a suggestion?
Developers, there must be one or two paying attention, is there anything I can try, or have I wasted my money on these OSD’s?

The bottom line seems to be that the MinimOSD will NOT work with all cameras, especially the newer higher line cameras like the KX-6.

Pity, cause it’s a nice OSD to use.

Still trying.

I read this link which gave me a few ideas.

So I tried powering the board only from the separate VTx battery and removing the APM +5v wire, giving me only 2 wires from the APM, signal and gnd.
I can get the HUD with no camera, or the video with no HUD.

So I tried powering the board from the APM with BOTH +12v and Gnd from the VTx bypassing the OSD and only video connected, which I did not think would work at all but it did, giving me HUD with no camera or video with no HUD. Note that the video did not work well, lots of flashing and drop outs, especially while the OSD booted up.
Same results as before.
??? :cry:

Did you solve the problem?

Have same issue with Turnigy IC-120SHS Mini CCD Video Camera. Camera looks same to KX6.
Bought it more than year ago and it was working with minimosd with KVTeam firmware for multiwii. But i have bought APM and flashed osd for APM and stuck.
When power connected i see only video from camera but if i disconnect and reconnect camera back osd is appear normaly on video until power off.

No matter how i powering osd. 12v or 5v only for both sides. Same result. Tried lowering power (camera can work with 5-12v). Same.

Spent few hours and still no solution.