MinimOSD + Telemetry on Pixhawk

Hello,

I am in the process of adding a MinimOSD to my setup for FPV. I currently have the telemetry radio plugged into Telem2, as the Telem1 port provides no 5V power to the radio.

Do I have to make the Y-cable to connect the MinimOSD, or can I just plug into Telem1 and find 5V elsewhere? Any good location on Pixhawk to get 5V?

Also, is the Telem1 port’s 5V just disabled until a firmware update, or is it not physically connected on the board?

Thanks,
Kevin

Hi Kevin,

You can make a Y cable, if you already have one but it is 5 pins you can modify it to convert it to 6 pins to make it work with Pixhawk. Please see: viewtopic.php?f=72&t=6545&p=12425#p12425

The Telem1 should be giving 5V it doesn’t depend on the firmware version, so probably it’s a hardware issue, you should send an email to help@3drobotics.com

I have telemetry plugged into the Telem2 port, and MinimOSD plugged into Telem1. It works fine, and powers both the OSD and telemetry module.

1 Like

That’s right benuntu,

Actually, our current documentation of the video kit added a section “Wire onboard components: Pixhawk and 3DR Radio V2” 3drobotics.com/wp-content/upload … ual-X1.pdf

I hope we can have the proper cable available at our store soon.

That document’s picture for the pixhawk needs to be updated. In the figure with the pixhawk it shows the black connector with 4 wires, and then just to the right the black connector has 3 wires when its connected to the minimOSD.

Which is correct 3 wires or 4 wires?

Hi,

My Minimosd works fine using a Fatshark vtx and goggles but when I added a 3DR radio last night and when that’s connected, it cuts the telemetry display to the goggles. Disconnect the radio from Pixhawk and it’s back in the goggles…

Do I have to enable anything to get the telemetry data to feed to both telemetry ports at the same time?

Thanks.

Peter.

You shouldn’t have to enable the Telem2 port, it should be enabled by default. Another thing to check is make sure you’re using the 6-wire cable between the Telem2 and telemetry module. And the the cable between Telem1 and the MinimOSD should just be 5v/Tx/Ground (1/4/5, where red is #1).

Hi,

My Minimosd works fine using a Fatshark vtx and goggles but when I added a 3DR radio last night and when that’s connected, it cuts the telemetry display to the goggles. Disconnect the radio from Pixhawk and it’s back in the goggles…

Do I have to enable anything to get the telemetry data to feed to both telemetry ports at the same time?

Thanks.

Peter.[/quote]

Thanks…

I’ve got radio in port 1 and Minimosd in 2, will try reversing them tomorrow evening…

Hi Peterev,

I don’t think you will get differences just by swapping the miniOSD to TELEM 1 and the radio to TELEM 2, both ports work the same way.

Please share more info about your connections, a picture would be great.

I didn’t change a thing in the config, and just switched the ports and it worked.

Great to know benuntu,

I hope this works for Peterev.

Thank you for sharing.

UPDATE: Peterev, confirmed the swap worked.

[quote=“RogelioN”]Hi Peterev,

I don’t think you will get differences just by swapping the miniOSD to TELEM 1 and the radio to TELEM 2, both ports work the same way.

Please share more info about your connections, a picture would be great.[/quote]

I believe Telem 2 can provide more power (current) for things like the RFD900 vs the Telem 1 is for low power items like the minimosd.

Also, make sure you don’t have the OSD tx attached. You need OSD Rx to PH or APM Tx.

I think you’ve got this the other way round telem1 port is higher powered and is designed to supply power to devices like the RFD900 while telem2 port low powered…while using this port for the usual 3DR telemetry module wont create problems but using it with the RFD900 will

You are correct. I had them reversed. There are two places or more where the documentation is in conflict but the schematics show Telem 1 to be the higher powered one. The 100mw telem radios will work on either but using the RFD900 at 30dBm will pull too much current.

Hi,

I got a 3DR pixhawk. Has anybody been successful in resolving this issue? I followed exactly the same directions given here but did not work. OSD mini and 3DR radio would work only on telem2. No any chance of having either one working on telem1. I used 3 wires for the OSD (no tx) and 6 wires for the radio. Both work flawlessly on telem2 but none on telem 1. I got the SR1 and SR2 params set the same but nothing happens.

Any clues would be highly appreciated.

Thanks!

Does anyone else have info on this?

I followed the youtubes but it doesn’t work (my radio can’t send telemetry with this setup), the pdf doesn’t help cause it doesn’t include the connection to the radio but it’s also confusing - page 4 shows the OSD connector with both 4 and 3 wirs - which is it and what are they?

Please please could someone post a full wiring diagram - Iris+, OSD, 3DR radio v2…

(youtubes I followed
youtube.com/watch?v=bPF59e75SgA
youtube.com/watch?v=x4CD1Y2mwvM