Servers by jDrones

Mini Talon QuadPlane Conversion (cont.)

Ron,

Yes, you are correct. My mind was in FBWA mode…still tired from my trip to Canada. :slight_smile:

I think your Q_A_RAT_RLL_P change to 0.2 is a good try. My Q_A_RAT_RLL and Q_A_RAT_PIT settings are the same. I can’t remember what your build looks like.

As for the Q_A_RAT_YAW_P change to 0.4, it was done years ago and I can’t remember why. My yaw control is solid yet still responsive to the sticks. The QuadPlanes can hold themselves better in wind than a tilt-rotor tricopter. Some folks look at QPs as being less efficient but they can handle more adverse conditions so it’s a trade-off.

Cheers!

I flew this morning with the changes. Pitch and roll seem better. Yaw is very slow, so I’ll try the higher P value next time around. Motors are nice and cool.

With the longer flight I got some data on current consumption. I haven’t calibrated the 2nd current sensor (where the quad motors are powered), but I got lucky on the battery usage and have a fairly accurate measurement of current used. I’m drawing ~30 Amps @ 6s in hover which seems reasonable. I have 4 T-Motor F40 ProIII motors driving HQProp DP 6x4x3V1SB propellers. Since each motor is capable of doing 30 Amps, I’m only using about 25% of the possible power to hover.

However, the motors don’t appear evenly loaded.

The front left and right rear motors are loafing compared to the other two. I’m guessing that this is to fight yaw, but it seems fairly extreme. In QHover, it’s quite noticeable, but in QLoiter the front left motor drops all the way to (what looks like) a minimum value for as long as 4 or 6 seconds at a time.

Could this be because I’m 10-15mm too tail heavy? Here’s a pic of the plane showing the location of the quad motors.


Current weight is 1910 grams, 548 of which is battery.

It could either be from CG, wind, or the direction of travel or a combination of these. My motors are not exactly the same either. The first image is in both wind and travel. The second is just travel with very low wind. The design of the mini Talon limited the positioning of the motors so mine are not perfectly around the CG. Remember that hovering is only meant for short periods…the plane mostly flies!

Roger, Im in the tunning process too with F80 motors, my pids are much lower than Greg for this kind of motors but Im still tunning yet, reduce D term too if you have high short wobbles.

My MT quadplane ha been collecting dust for more than one year. Yesterday I updated the firmware to the latest stable one (was at 3.8.5 I believe). I had a test hover today and everything seams to work as it should. Hopefully I can get it out flying again soon :grinning:

Hi Ron,

Welcome back! :slight_smile:

I updated my MT VTOL this summer, and, other than burning out the forward flight motor, it still works fine. It was strangely fun to figure out why the plane was just “sitting” there in FBWA mode during a flight. It finally dawned on me that the Q_ASSIST_SPEED feature had kicked in.

1 Like

Thanks Greg. I read about your motor failure yesterday. Good thing that the code is mature and robust enough to catch such events :slight_smile:
It lives to fly another day :slight_smile:

I did my first transition today. Went fairly well. There’s a full video of the flight from takeoff to landing at https://drive.google.com/open?id=1101sCX5myu2gmCXyuK66179cdvlK841f. It’s only about two and 3/4 minutes.

The first 1:09 shows takeoff and transition (transition starts at about the 47 second mark). The next minute of video is fairly useless as plane is too far off (or in the sun) for the phone to record it well. I only did one loop round the field. From 2:15 to the end (at 2:42) shows the descent and landing. The descent is fairly slow…at one point I was concerned it was holding altitude with the throttle pulled all the way back…but it was descending and eventually made it down. I’m not sure what parameters to adjust, but a faster descent seems wise…30 seconds from 100m down to the ground seemed about twice as long as I’d call reasonable. However, it was a very consistent descent.

Good eyes may notice some misbehavior during the forward transition. I currently have transition set up to occur by turning a 6-position selector switch from QHOVER to FBWA. Those two modes are adjacent on the switch. However, I currently have MANUAL mode one more click over. By mistake, I went from QHOVER to MANUAL (the dial was turned fast enough that the intervening FBWA selection never registered). About 6/10ths of a second later, I realized my mistake and switched into the proper mode (FBWA). The four quad motors shut off about 3/10ths of a second after the mistake and then come back on at a high level after about 3/4 of a second. Bottom line is…don’t switch to manual when not flying forward above stall speed! I am now planning to remove manual mode to avoid this possibility in the future.

Those with good eyes may also notice a flashlight (temporarily) taped to the nose :grin:. I’m not sure how I managed it, but I’m very tail heavy and needed the weight to get the CG correct. I’m probably going to order a larger battery (currently running a 4000 mAh 6s). I am also planning to add a video camera/VTX and canopy on the nose which will add a bit of weight.

Hi Roger,

Congratulations on your maiden transition! The flight looked fine and you will gain experience with each flight, making lower transitions back to QHOVER or QSTABILIZE modes. On my VTOLs, I also remove MANUAL mode since QSTABILIZE is my emergency go-to mode.

Many of us (including the non-VTOL FPVers) have heavier cameras with gimbals on the front pod so it is good that you are tail heavy until you figure out your own setup. Mark_Q on RC Groups has designed many 3D printed options for the MT. I use a 4s 8AH pack with a single axis Mobius gimbal and still need to add weight up front.

Good luck on your future flights!

Using my largest battery pack, I finally managed to get q_autotune to finish on the roll axis for my mini-Talon. I first reduced Q_A_RAT_RLL_P for the roll P term from .20 to .15. After the flight:

  • Q_A_RAT_RLL_P was almost back to before the change with a value of .1995105.

  • Q_A_RAT_RLL_I had exactly the same finsihing value as P at .1995105

  • Q_A_RAT_RLL_D finished at .005194611

I tried to do the pitch axis using a slighltly smaller battery but had to abort before completion.

RR

1 Like

An update on Q_AUTOTUNE.

I found the log data showing the parameters that pitch was moving to. Even though the tune didn’t complete, it was on step 4 (of 4) and the values were reasonable and stable.
So I set

Q_A_RAT_PIT_D to 0.0657

Q_A_RAT_PIT_I to 0.227

Q_A_RAT_PIT_D to 0.227

I noticed oscillations later and backed off a little. Ended up with D at .0557, I and P at .217.

It took a few tries, but I got yaw to autotune as well. These numbers are way different than Greg’s.
Yaw appears to not use a “D” term. It’s 0.
Q_A_RAT_YAW_I = 0.1632059
Q_A_RAT_YAW_P = 1.632059

I’m not entirely sure if these are good numbers, but it was flyable and seemed much more responsive.

However, I then encountered a problem while executing a dive in forward flight. In FBWA, I started a dive at about 100 meters and attempted to stop the dive at ~50 meters. The plane would not pull out of the dive and hit the ground at about 40 MPH. Fortunately it was almost level at that point, so damage doesn’t appear extensive and I should be able to test more when the weather settles down.

Ouch! I hope the MT is ok. Try increasing your MIXING_GAIN a bit for more stick control.

Good luck!

So sorry for your crash, Im curious why the quad can´t save your plane to be attent when I fly mine, you cant switch to quad modes or the quad cant be able to rescue?

Greg: Thanks for the mixing gain tip. That might help. However, I decided to relocate the tail servos to the fuselage to avoid interference from my RFD900 antennas. So I also need to double check that the remote linkage isn’t allowing unwanted deflection of the control surfaces when under high stress. I think I have sufficient telemetry data to figure it out in time.

Cala2: I have a 3-way safety switch on my TX. Down is manual mode and throttle is forced to zero. Middle is forward flight (currently limited to FBWA). Up is vertical flight, with the selected mode (QHover, QLoiter, QRTL) controlled by a rotary switch.

I should have flipped the switch to quad mode for recovery! But I didn’t. My rotary switch was in QLoiter and switching to QLoiter in the middle of a dive at 50 or so MPH would have been a very abrupt control change. However, n retrospect, it would have been far better than continuing to fight for control in forward flight.

It’s also possible that Manual mode might have allowed more elevator deflection. I didn’t try that one either.

We need more channels to flying modes in planes as it is in copter, I have switches in my radio and can rescue an expensive flying wing when dive, much easier to react during an emergency than rotary switch, Im try to add to github.

I agree. It is a very nice copter feature that should easily port to plane.

1 Like

Hi Roger,
did you perform AUTOTUNE, not Q_AUTOTUNE ( http://ardupilot.org/plane/docs/automatic-tuning-with-autotune.html#automatic-tuning-with-autotune ) ?

Q_Autotune only tunes the parameters for the Q modes. For plane modes like FBWA, Autotune is the corresponding mode.

For security reasons you could also activate Q_ASSIST_ALT (Plane 4.01).

Rolf

Rolf,
I was planning on Autotune in my next flight, but hadn’t gotten to it. Wanted to get the vertical modes correct first.

I flew today for a bit. Before flying, I tweaked a few of the PID values for pitch and modified the mixing gain value. I was going to autotune forward flight today, but I neglected to hit save in Mission Planner when I changed the mode. So, that will take another flight.

I will consider setting Q_ASSIST_ALT. It would have helped in this incident.

RR

I performed a forward flight Autotune this morning. Ended up with

  • PTCH2SRV_D = .197955

  • PITCH2SRV_I = .125

  • PITCH2SRV_P = 2.639

  • RLL2SRV_D = .09439

  • RLL2SRV_I = .125

  • RLL2SRV_P = 1.2586

FYI, my plane is about 2 KG. My CG is about 55mm front the front edge of the wing.

These values seem to work much better than those I had previously. Roll used to be close enough to work, but pitch was quite different (old values were D of .04, I of .3, and P of 1).

However, I notice that the plane doesn’t seem able to hold pitch during sharp turns. Even with full up elevator, it loses altitude.

I’ve also determined that my Q_Autotune values for yaw are not good. There was very light wind today and the plane would yaw around. Attempts to stop this with stick input resulted in faster circling. Only when the plane was pitched or banked did the yaw settle down.

1 Like

Thanks for share your values. Check if your arms are enought stiff, thats a common yau issue in vtols.

Servers by jDrones