Maxbotix sonar not working in flight


I have a sonar Maxbotix 1202 on my copter (facing forward). When the copter is on the ground everything works fine, I have the correct data returned and even if I arm and keep the motor rpm low, it’s still working fine.
But when I take off my sonar only return 765cm (which is just the default value if it doesn’t detect anything).
Any idea of what can be the problem?

The sonar is mounted on foam and there is a current filter to avoid perturbations.

The sonar has a problem with air movement upsetting its readings.
Where you have it mounted, how are you avoiding the prop wash?
They were never really successful on multi rotors

1 Like

I put it below the drone so I was thinking there is no problem. May be should I put it on the top? Over the props?

If it doesn’t work what kind of sensors is better (I can’t use lidar)

I just tried with the sonar 10cm above the props and I still get the same issue. What is strange is that when I land, I get the data back