Servers by jDrones

Mavproxy startup option


(Tomasz) #1

Hi All
I have question about mavproxy startup.
I installed intel edison on my new pixhawk 2 and debian, wifi works ok. Mavproxy starts with following command
screen -d -m -s /bin/bash mavproxy.py --master=/dev/ttyMFD1,57600 --source-system=1 --source-component=100 --logfile=/home/edison/mav.tlog --state-basedir=/home/edison
What should I change/add in to be able to connect from remote Mission Planer thru TCP ?
regards


(Khancyr) #2

Hi,

I invite you to read Mavproxy docs ! You will find some valuable information.
To connect from mission planner , I will recommand you to add something like --out=udpbcast:192.168.X.255:14550
and changing X by the address of your network . See here for more explanation : http://ardupilot.github.io/MAVProxy/html/getting_started/starting.html#out


(Tomasz) #3

Hi
I add out=udpbcast:192.168.1.255:14550 but it doesn’t work. I can’t connect use Mission Planner


(Stephen) #4

Have you confirmed that the Edison and computer running Mission Planner can ping each other?

Mission Planner will need to be connected via the UDP option in order to use the --out=udpbast option.


(Guy Tzoler) #5

Hi

Did you got the udpbcsat to work?

i got a connection when using udp and a direct ip addess as in --out 192.168.1.1:14550

but cant get it to connect when starting --out=udpbast:192.168.1.255:14550

any ideas??


(Stephen) #6

That should be --out=udpbcast:192.168.1.255:14550


(Guy Tzoler) #7

typo was here only not when running the command … anyhow tried again to make sure Mavproxy starts well (without typo with typo get and error “UDP ports must be specified as host:port”), but still when setting Mission planner to UDP on port 14550 it work when i specify the exact IP on mavproxy (Companion computer), but when i set the --out=udpbcast:192.168.100.255:14550 Mission Planner won’t connect… thinking about it from the mavproxy documentation it says " UDP broadcast then locks onto the first client that connects." how does mission planner should connect i am not giving mission planner the companion computer IP…


(Nikita) #8

Are You sure that You dont mix networks? cause --out=udpbcast:192.168.100.255:14550 will try to find listeners from 192.168.100.1 to 192.168.100.255. Earlier You mentioned that --out=192.168.1.1:14550 worked.

Nikita


(Guy Tzoler) #9

Hi

the network is setup like that:
GCS IP: 192.168.100.139, Gateway 192.168.100.1

Companion computer is outside of this network connected Via 4G LTE modem using VPN to my network, its IP is 172.31.0.10

to make sure i got the connection i ping them both vise versa and ping works both ways, so the route is in place.

starting MavProxy with these options work well:
–out=udp:192.168.100.139:14550
–out=udpbcast:192.168.100.139:14550

but when trying:
–out=udpbcast:192.168.100.255:14550

mission planner won’t connect.

what i don’t understand is as i said:
the mavproxy documentation it says " UDP broadcast then locks onto the first client that connects." how does mission planner should connect as i am not giving mission planner the companion computer IP endpoint…


(Nikita) #10

MP acts as client, when You choose connect via UDP, MP will ask You about incoming UDP port, which is 14550 by default. MP doesnt ask for any IP, since it is incoming connection.

So I see it like, You start streaming with Mavproxy, and connect with MP to UDP and choose default 14550 port.

Nikita


(Guy Tzoler) #11

this is all correct with regular UDP which is working great, the idea of UDP broadcast is a bit different …


(Guy Tzoler) #12

looks like the
mavproxy.py --master=/dev/ttyUSB0 --baudrate 1500000 --out=udpbcast:192.168.100.255:14550

works when the Companion computer is connected to the network directly without the VPN and 4G LTE modem … so it is probably a network and not mavproxy issue … will debug sometime … for noew i’ll use direct IP…

thanks for the ideas…