Mavlink low Quality, high packets loss rate

Hi, I’m zigbee xbee pro 900hp for communication on my drone.
I have already configure the zigbees and they can successfully talk to each other (both able to receive and sending when testing on XCTU).
However when connecting with Mission planner, it shows very low mavlink quality, it hardly reads parameters and took a long time. Some times it just time out without the connection being established.

Thank you very much for any advice.


XBee modules have re-send capabilities that mess up the MAVLink communication.
Disable that option from XCTU.

thank you for your kind help, do i just change the routing mode to do that? Or which parameters do i change?

Hi @nina_wang , have you figured out the solution?