Manually Test Servos by Mission Planner only without Transmitter?

how can you manually move the servos from the mission planner?
my servo is connected to the cube rail and getting powered by a separate 5V output.

I cant seem to find the tab where you can select your servo and slide a bar with your mouse
to make the servo move…
is that not a feature that is available?

only by radio telemetry?
I would like to move it without any radio gear for testing.

No, it’s not.

You could use FBWA and move the plane (or FC) around to see if the servos are moving. You’ll need to do that anyway to make sure it’s set up correctly and travel is in the correct direction. It won’t give you the full travel that you may be looking for right now but at least you’ll know the servos and stabilization is working.

how come its not possible , isnt that easy to implement?
why would this task be skipped.

is there any other GCS that supports this feauture, since qgroundcontrol and APM2
both seem to have much fewer configuration options then mission planner…

or is there a way to simulate a radio transmitter to make the servos move?

Post that in the Mission Planner thread.

Give this a try.
Ardu-Configurator

Or you could try MAVProxy:

https://ardupilot.org/mavproxy/docs/getting_started/cheatsheet.html

servo set N PWM
1 Like

you can use the Initial Setup > Mandatory Hardware > Servo Ouput menu in Mission Planner and change the trim values from typical 1500pwm to either 1000 or 2000pwm. Servos will move. Other approach is to setup a joystick from the Optional Hardware menu to move the servos. Last resort is to assign RCIN# as Servo Functions in thr previous menu and then to go to Flight Data> Servo tab and set the relays to Low or High values…

thanks thats it albcem, but I had trouble finding out that you also need to have a GPS plugged in otherwise MP doesnt allow you to arm failsafe.

You can force it to arm in mission planner or disable that specific failsafe check for bench tests.

you can use the servo tab inside mission planner, just not on the first 4 channels