Manual Flaps Not working

For some reason manual flaps just do not work

I have set

Flap_in_channel 5
RC5_OPTION 208 (flaps)
SERVO5_Function - 2 ( flaps ) and tried 3 ( autoflaps)

When I switch the manual control, and move the flap switch ( checked it worked on that channel via a passthru ) there is no servo output.

Any ideas ?

Thanks

What kind of controller are you using? Are you connected to the main or aux outputs?

Can you post a log or parameter file?

hi you need to update the controller that firmware is not supported any more

Archived:Channel Output Functions

https://ardupilot.org/plane/docs/channel-output-functions.html

try setting RC5_OPTION,0 i have flaps on all my planes never had to set rc options ( RC5_OPTION 208 (flaps) )

Using the RC channel option is a better option; the scaling is set on the
autopilot and RC-failsafe values will more likely be correct over time.

Further, if you choose to deploy flaps automaticaly during landing that
will be easier to accomplish.

Thanks for the help , setting the rc option back to 0 sorted it, i didnt read the page properly

It is interesting, with update 4.16 I have needed to set the RC channel to 208 to enable manual control of the flaps. Until now, the RC has been set to 0. Both my aircraft have had the same symptoms and the correction worked on both.