Maidenflight unstable flight and altitude hold problems

Yesterday I did my very first copter flight with my own build hexacopter.
It has a pixhawk and APM:Copter V3.4.6 (e707341b).

It was my first copter flight also and I used the flight modes “Stabilize”, “AltHold” and “Loiter”.

First problem I am facing is, that the copter is really hard to fly.
It drifts horizontally and it was nearly impossible to holt the altitude at stabilize mode (always bouncing up and down…).

On “AltHold” it just goes down slowly… until it crashes.
The same with Loiter.

If I try to land the motors always spins too long causes the copter to land and fall to the side.
I tried the failsafe on a remote lost and turned it off.
The Failsafe was set to "always RTL"
The copter rised always 2m (instead of 1,5m) as I was already at the launchpoint at 1m off the groung and one time I was 4m away from the launch the copter raised to 7m… came back to launchpoint and landed slowy… until it hits the ground … keeps the propellers spinning… fall off the side, cut the grass and turned the motors off about 2 sek after falling to the side.

I downloaded the logs but there are so many informations that I dont know where to start at improving the stability.

Before I started I checked that I had no prearm messages and a 3D fix.
After the maidenflight I have a “inconsistend compasses” warning.
the GPSmodule and the pixhawk hasnt moved since the testflight.

So now: Where to start at best and what kind of information do you need to help me ? :smiley:
Thanks a lot guys!

You should check that the Esc calibration has been done perfectly , then redo radio calibration with all trims to center.

The copter must fly well in stabilize mode after you can try the other modes.

Loiter need a perfect compass calibration and a good Gps signal.

Ok there have been a problem with my sonar telling the copter its higher than it was.
But As you meantioned I also did another calibration of the ESCs and the Compasses.

I still got a “inconsistend compasses” error that didnt appear before.
So I just disabled the internal one and using the one of the GPS module instead.

After this AltHold and Loiter works great.

Today I wanted to do the AutoTune process to give my copter better PID parameters.
The Problem is, that it needed long… verry long.
After 12min it just finished the roll tuning on a not so windy day (6km/h).
Then it started to tune the tild PIDs.
After another 3min I had to land because Battery was too low.
So I couldnt finish the AutoTune.
I kept the “AutoTune-Switch” to high and landed still in AltHold mode.
Then I disarmed by the remote, then on the switch of the copter, removed the battery of the copter and turned off the remote.

I went back home, started Mission Planner and NOTHING has changed in the PID settings…
Not even the Roll PID parameters changed after this 12min tuning.

So what did I made wrong and what can I do to finish the tuning faster?

OK… NOW I have some serious issues!

As the AutoTune Process didnt complete the last time I fully charged my battery again and changed the AUTOTUNE_AXES from “7” (all axis) to “1” (Roll only)

The reson was that I wanted to finish the roll axis, save the settings, and then do the Pitch axis after it.

So I started in Stabilize and took the Copter into a good position at (about 2m off the ground) for the autotune.
Then I switched to “AltHold” Mode…
Suddenly the Copter rised more and more.
I decreased the throttle but the copter didnt react to my commands.
It was already at 5m and the only idea I had was to bring it back to “stabilize” mode.
Then the copter turned the props off and fell off like a stone.
The copter was upsite down and beeped (I thought it was disarmed).
I turned it around and it started to spin the props.
I threw it to the ground, disarmed it and looked at the damages and did repair as much as possible.

I connected my notebook to the copter and looked if there were any warnings or massages, but it all looked great.
So gave it another try.

Started from stabilize mode… turned it into AltHold and ift holded the Altitude (like this morning…).
I then fly a little up and down, checked Pitch and Roll and everything looked good.
I brought it back into a good position to start the Autotune Mode and started it.

It started the turns to the right and left to tune the Pitch axis and I thought everything is fine now…
After 3-4 turns it stopped and again lifted up…
Again I had no controll about it!
As the copter was at about 10m I again had no idea “how high” this copter will go and to avoid more danger I switched to “stabilize” mode.
The Copter turned off the motors and fell off again like a stone.
This time I turned the “AltHold” mode on again as it was fallen down to 3-4m…
It then started the motors and stabilized at 3m… and started fast increasing the position.
I then switched again to stabilize Mode, let it fall down to the ground and have now broken hardware with a value of 50USD…

So what is the problem here?
The only thing I have changed since my 14,5min fly (without issues) from this morning was
AUTOTUNE_AXES from “7” (all axis) to “1” (Roll only).

I hope someone will jump in and help my figure out what the problem(s) is(are).
Sadly I cant read the log file (but I donwloaded it already).
The logfile of the first fall off says “Err: FAILSAFE_RADIO-1” before the altitude raise began.

The Logfile of the second falloff is completely missing :frowning:

Thanks a lot!

Without a log file it impossible to diagnose what might have happened.

Taking off vertically as you describe is usually a sign of high vibrations getting into the flight controller.

Falling as you describe when switching to Stab is usually because you have reduced the throttle to zero in Althold without effect before switching to stab.

Looks like your copter loose radio signal and went in RTL failsafe , this would explain why it started to go up , if you had put the throttle stick down trying to keep it down when you returned in stabilize mode the motors were at lowest rpm and the copter began to fall down.
Obviously it is just my 2 cents…

Thanks @mboland and @lucamax for your help.
I just looked at the logs (really hard to read for a newbe) and can confirm, that the signal on all channels was lost for 2 seconds.
I thought that my failsafe was set to “increase 1,5m and then RTL” but in fact I missed a ZERO and it was set to “inrease 15m and then RTL”.

As when the RTL was triggered I had no idea what was happening I turned down throttle further and further to 0 (value of 1000 in the log) and THEN switched to stabilize mode…
So the FC did everything right and it was just my fault so far.

On my first flights I always had the copter wired (with a 7m wire) so that I will have no flyaway and dont cause any damage to others.
After I “unwire” the copter I fly to longer ranges (still not more then 20m) and I see really often a signal loss and the failsafe triggers (now that I know that I didnt crashed it).

The last 5 flights was all about the autotune.
As “all axis” dindnt complete (battery was down before) I just autotuned one axis after the other.
The autotune of the roll and pitch axis needed nearly one battery charge each (about 12min) to complete
At the roll axis I had a “stabilize roll” P-value of 21.xx ( I dont remember the “Rate Roll”-PID values).
After every axis was tuned one by onw I started Autotune again for all axis.
Now I have a “stabilize roll” P-value of 5,87 …
I know that the “Rate Roll”-PID parameters are related and important but I’m also a bit confused that the “stabilize roll” P-value has a difference of 15 now.
On the tuning the copter was always near me (about 10m max).

As the Autotune for all axis had finished (after about 8min) I landed, saved the parameters and did a fly on stabilize mode.
The values looks to be good but I cant test it really.

On that 4min fly I had 5 failsafes at not more then 20m away.
The longest “no signal” period was at 15m away for 11 seconds!!

I have a Turnigy 9x transmitter with stock RX and TX module and read (and saw on youtube) ranges at about more then 1km…

So now I am facing a signal lost issue on my TX/RX.
I hope anyone can help me finding the reason for it.

Thanks a lot guys!


some times the barometer of the APM fails. I think is a quality problem, one time a just new APM arducopter show me different altitude beteween the Bar_alt and GPS_alt, so when I change the mode to Loitre or any mode use this reading,the drone start to up and down. As the RTL use as weel this data, you will have the same issue using it to come back to home.

The solution is to change the APM.

the barometer go bad too if the APM falls a quite hard. That is my experience

The first thing you need to do is flash the board with the rover or helicopter firmware to clean out the trash, and then you need to flash the latest version AC3.5.4, then start from scratch, and ditch the sonar…

Next, upgrade the radio with a FrSky XJT TX module and upgrade the aircraft with a FrSky X8R receiver. Radio problems solved…

When you do the maiden flight, the first thing you need to do is run AutoTrim and save the settings. This will make the aircraft easier to fly.

The next thing to test is AltHold. Without the sonar it should work just fine…

If AltHold works then you can test Loiter.

If Loiter works then you can setup your failsafes.