Servers by jDrones

Lost signal on flight and caused crash!

Hi guys
Please if anybody had This issue beside me…

Today was trying my first hover of my very nice scale UH1N 450 size with pixhawk 1
Just before the hover the FRSKY reciever disconnected and connecting every 2 seconds for about 5 min
And then I unplugged the battery and re power it again
The green light was good and I was able to arm
Then 3 seconds after hovering to about 4 feet high
I lost the connection and I saw the mission planner gave me message of fail safe on
Then no control and the model kept going out of control till it hit the wall then turn around and went to dive into the ground
Causing of 70% damages to the fuselage and the mechanics
Is there a way we can set parameters so that if this happen the heli will stay there hovering without going anywhere or maybe land itself without radio input ?

My radio 14sg
Set on FASST-MULT G
And using TFR8 SB
I had same issue before with my other heli but it was on ground when I was doing some setup
I tried to use FUTABA R7008sB but that one also was lossing connection every second and drove me crazy for 5 hours then it just worked fine!

Now I have my FRSKY reciever back in that heli with no problem
But this time this little heli crashed with same problem
I am not going to use my futaba radio or any of my receivers till I make sure there is safe way to put the model safe on the ground when I get into same problem !

I appreciate any help
Ozzy

Yes. Please read about the failsafes and properly configure all before flight.
http://ardupilot.org/copter/docs/failsafe-landing-page.html

Servers by jDrones