Loss of Thrust Error - Yaw issues - Logs and Video Provided

Would someone mind taking a look at this log for me?

I am suspecting 2 bad motors on this drone as motors 2 and 6 are SIGNIFICANTLY hotter than the rest after even this short flight.

XFold Dragon Frame
Pixhawk Cube Black
8x T-Motor U11 - 120KV motors w/28x9.2 props
8x T-Motor 80Amp ALPHA ESCs (matched to the 120KV spec)
2x 16,000mAh 12s Tattu Lips (15c rating each) wired in parellel

Total ALL UP WEIGHT for this flight was 65lbs.(35 for drone, 20 for batteries , and 10lbs of payload weight).

During the initial flight the YAW is Very sluggish. It overshoots really bad and was hard to fly. I did an autotune on roll which completedly succesfully (different flight than this one). This flight was to tune the pitch. During the autotune process you will see it YAW’s badly and drops altitude (video is in the folder below along with the .bin and .log files). It did this three times then I decided to come land.

I’m suspecting 2 bad motors that are underperforming. Would love to hear your thoughts as well. Thank you.


My first shot looking at an Octo log so here goes:

Yes, 2 & 6 are running at significantly higher values than the other motors. In fact they are maxing out at a few points. That’s probably when the quad makes the uncommaned yaw movements, there just isn’t anything left to stop it. Motors 3&7 on the other hand are running lower than the others, also suggesting that 2&6 aren’t cutting it.

There is a higher level of vertical vibration that seems to track along with speed changes in 2&6/3&7. Before swapping motors/ESCs. I’d have a look for mechanical damage. Either prop damage or installation (can you put a prop on backwards on this?) Maybe a motor bearing is bad?

Thanks for the feedback. I have confirmed that the props are on in the correct spots and properly secured.

Possibly bad bearings but there is no excessive play in the motors (actually non at all) and they are brand new. Literally 2 flights on them. Doesn’t mean there could be something internally wrong with them however.

OK, connect to MissionPlanner and press Alt A on the keyboard. Step through that dialog and accept and the values it gives you except
Then set these:
MOT_THST_EXPO,0.4 (02. to 0.4)

Try doing the ESC calibration again, but it might not do anything with those Flame ESCs.

Get side on to your QuadX8 and check that all the props are turning in EXACTLY the same plane and that none of the motor mounts are twisted. You can use a straight-edge across the motor mounts too. Each prop tip should “point” to the next prop tip.

You might want to copy the Roll PIDs to Pitch.

Now do another test flight without running Autotune, see how that goes.

If some motors are still going being commanded to maximum as if the motors and ESCs have desynced, then you’ll have to throw away those Flame ESCs. It’s been seen a lot.

1 Like

I’ll give that a go. These are the ALPHA esc not the Flames however.

Also the XFold frame is all square tubing. You can’t adjust and everything is level. I checked that. Here are some images.


Hopefully not your case but forum is full of horror stories on big machines and t-motor combos. In my personal experience they caused so many probs that i switched over to hobbywing x8 and x6 on all my builds and never had a problem since.
It could be desync you see in flight, Alpha are known to do it, expecially during autotune, where abrupt commands are applied.
The rcout inbalance during loiter is maybe due to the uav being nose heavy a bit, you can see it from the rates on the log, while mean roll is zero, mean pitch is around 0,10, it means that to keep the uav plane it has to apply 0,10 of p rate all the time (nose heavy)
Vibes are not a problem let alone bearings…

I must add that we use t-motor on smaller builds (up to 10kg) and they perform very very well, not on the big ones tough.

Thanks for the info.

If it was nose heavy wouldn’t it be seen in motors 1 and 5 as well?

That depends on how the firmware uses the motors. Being nose heavy is a fact, rates do not lie, drone applied 0,10 pitch to keep level the entire time is in loiter.
It is just my opinion anyway :slight_smile:

If you make a search on the forum alpha desync, there are some very informative threads about it.

Thanks so much. I’ll look into it

Hey Guys,
Finally had time to look back into this again. I decided to make sure the motors were all in the correct positions so I took the props off and did a spin test. They are in the correct positions but the two motors that were really hot during the flight (2 and 6) sound very different from the rest. I took video of them sounding different (throttle set to 10%) then decided to increase the throttle to around 30-35% and all the motors were fine, except 2 and 6. Both started to desync almost immediately. After this happened I attempted to film again but neither of those motors would spin up again. After a power cycle of the system, they did start to work again but still had the different sound.

Do you think this is due to two bad motors or 2 bad ESCs? I’m leaning more towards the motors personally but curious your thoughts too.

Video of the different sounds:

Video of the 2 motors not spinning:



Those ESCs will be bad and you’ll find they will fail spectacularly soon, possibly destroying the motors. Test the motors now with good old Hobbywing Xrotor ESCs or something reliable like that, so long as they suit you battery voltage.

Will do.

I do have a set of KDE 95amp escs laying around which are rated to 12s. Any thoughts on those?

Those Hobbywing Xrotor Pro 80s are really hard to find right now!

KDE ESCs should be very good.
I haven’t ever had the chance to use KDE gear but I understand it is high quality.

Found a set of 8 HW Xrotor 80amp. Ordered and hoping they will be here quickly.

Once you have got the new ESCs hooked up set these
and run the semi-automatic ESC calibration

If using the new ESCs with the old motors and props set the thrust expo based on the prop size, rather than the “special” T-Motor ESC settings, for 28" use MOT_THST_EXPO,0.79 then adjust it as per:

  • set too high you can see instability at low throttle
  • set too low you can see instability at high throttle

If you are using the entire combo, motors and ESCs combined, then @Corrado_Steri might be able to advise the thrust expo to use.

I’m FINALLY getting back to working on this thing. I have all the new ESCs in the drone and everything powered up. I followed your advice with these settings but I can’t get the ESCs to calibrate.

I set ESC_Calibration to 3. Powered everything off, then powered back up. Hit the safety switch and it makes two short beeps. Pauses for a second then does 3 quick beeps then one slightly longer one. After power cycle I am not able to spin any motors using the motor test feature or by simply arming the drone.

Any ideas??? Thanks!

I did a manual calibration (started everything off. Throttle to 100%, bla bla). Anyway that resulted in the same sounds (2 quick beeps followed by 3 short beeps. Then went throttle to 0 and it did a longer beep. After this I can move the throttle up and it starts motors. 7 of the 8 start fine HOWEVER motor number 2 needs a touch more throttle before it starts compared to the other 7.

After this when I go to arm the drone the motors spin up (had to increase MOT_SPIN_ARM to .15 before they would start) but motor number 2 still won’t spin up until throttle is added. All the other 7 will spin at a slow speed until throttle is added. Any ideas?

I did try a semi-auto calibration. Still get the same beep combo as before but have the same issue as listed above with motor 2 not spinning as soon as the others.

And the 3 beeps is odd since I thought it was supposed to beep the number of cells it sees? MP is showing the correct voltage for 12s so not sure why the ESCs are only beeping 3 times.



Increase the MOT_SPIN_ARM slowly in increments of 0.01 until all motors start reliably