Servers by jDrones

LOITER problem - slow response

I’ve some issue with loiter on new cube black. While PID process (manually) I can’t set MR to crisp stop on Loiter (while stick is centered or even switching between ALTHOLD to LOITER -Always slowly stop- 3-4m slide/drift (Loiter behave like on POSHOLD) . LOIT_xxx params is set to max for crisp response . This is very strange because on cube orange on same setup, copter in default is stoping imediately (must to decrease LOIT_xx params because is too sharp). Also POSHOLD mode did not work it switchto POSHOLD but works like ALTHOLD

PS. Basicaly LOITER works, it hold position very good.

LOG

Increase LOIT_ACC_MAX (default is 500 cm/s/s you have 100)
Increase LOIT_BRK_ACCEL (default is 250 cm/s/s you have 80)
LOIT_ANG_MAX set at 0 will be 2/3 ANGLE_MAX which you have at 3800 so ~25°. You could increase this.

Sorry, wrong .bin file - but like You wrote, these are parameters for same setup but cube orange. I will post proper .bin tomorrow.

Try these:
LOIT_ACC_MAX,600
LOIT_BRK_ACCEL,300
LOIT_BRK_DELAY,0.3
LOIT_BRK_JERK,300

Could You check proper log ?

Could You check proper log ?

Did you update it in the link above to the correct log?

Yes, new link in first post .

Drop the Loiter delay to what @xfacta suggested. You could set a value for LOITER_ANG_MAX also. Right now It’s a percentage of ANGLE_MAX. Or increase ANGLE_MAX

I think tuning is a contributor here.
I would set those Loiter params posted before, plus I would set all these:
ATC_THR_MIX_MAN,0.5
PSC_ACCZ_I,0.56
PSC_ACCZ_P,0.28
ATC_ACCEL_P_MAX,60000
ATC_ACCEL_R_MAX,60000
ATC_RAT_PIT_FLTD,17
ATC_RAT_PIT_FLTE,0
ATC_RAT_PIT_FLTT,17
ATC_RAT_RLL_FLTD,17
ATC_RAT_RLL_FLTE,0
ATC_RAT_RLL_FLTT,17
ATC_RAT_YAW_FLTD,0
ATC_RAT_YAW_FLTE,2
ATC_RAT_YAW_FLTT,17
MOT_THST_EXPO,0.69
BATT_ARM_VOLT,22.1
BATT_CRT_VOLT,21
BATT_LOW_VOLT,21.6
MOT_BAT_VOLT_MAX,25.2
MOT_BAT_VOLT_MIN,19.8
BATT_FS_CRT_ACT,1
BATT_FS_LOW_ACT,2

Then I’d run Autotune at least, if not step through the Harmonic Notch filter setup then run Autotune.

That log file has lots of radical stick inputs, maybe just fly around more gently in ALTHOLD and then LOITER, and do some hovering - let’s see what that log file looks like.
Also you battery voltage was getting low, maybe check the calibration of your voltage and current sensor.

Also try ATC_INPUT_TC,0.22 or at least a bit higher than 0.15

Thx, I will try Your suggestion and let You know. Could You also check why POSHOLD did not work.

i have the exact same problem, but also on orange setups (different units of same quad, slightly different payloads etc)

New LOG

also video.

Radical stick input was for PID purpose and to check if it perform well. LOITER holding position quite well - when it stops. POSHOLD still did not work.I’ve spoted something else Yaw slowly turn left on LOITER ( checked motor>compass interference - always near 0).
About Autotune - I’ve try it 3 times in the past and 3 times after Autotune Copter crash - bad PID. I’ve sets around 50 cube’s without big issue but this one behave unusual (it return from repair)
Besides, the copter flies very well .

I think I found the problem. Your RC deadzones are 0. Set RCx_DZ to something like 20 or 30 for RC1, RC2, RC3, and RC4.

PosHold doesn’t work at all because it acts like althold whenever the pilot is giving an RC input that is outside of the deadzone. Loiter is sluggish for the same reason - I think it is not braking at all, just slowing down to follow your very small control input.

Edit: You will probably want to reduce your LOIT_BRK_* parameters to be like your Cube Black. Once you have the deadzones set up, Loiter will start braking properly and it will be very aggressive with your current settings.

@Anubis that sound plausible. A pre-arm check should help with this. Any volunteers for a lua proof of concept pre-arm check script?

I’ve checked all my parmas from different copter and always RC1,2,4_DZ is 0 and never had problems like this. BTW on Loiter when copter stops is holding position very well . Of course will try set DZ >0 and give a try.

Hi Anubis,

i just checked my setup, i have 20ms DZ on CH1, 2 and 4 and 30 on CH3 and problem is still there.

Can you post a log and param file from a good flight on one of your other drones?

Servers by jDrones