Loiter Mode Not Working

Hi everyone,
today I wanted to do my first Loiter flight with my drone.
I increased the throttle slowly after 50% and it started going up then I quickly brought the throttle to a minimum but the drone kept going up to prevent it from going out of range I disarmed it and it plummeted to the ground.
I have set a geofence with a maximum altitude of 10m and from the logs it seems that it when over 15m.
Can anyone help?
I really appreciate any help you can provide.


The Fence was breached, Failsafe was RTL which is what it did. If you took no action it likely would have landed at the home position but there was a GPS glitch also. In any case you should have switched to Stabilize and flown it down.

It’s a bad idea to fly on default parameters. That’s what the Initial Parameter Setup screen in Mandatory hardware is for. Pre maiden flight settings.

1 Like

I have run throw the Mandatory hardware configuration and I did adjust the parameters accordingly.
The default parameters that you refer to are the parameters for tuning like MOT_THST_HOVER?

I don’t see any evidence of that. These are all at default:
All the Rate Filters

Page down to the bottom:

Thank you for the information.
I have now changed this and ASAP I will test it and report if it flies better.

Don’t be so hasty to get it in the air. The only reason to do that is to test it’s resiliency to a crash😉
The Dynamic Notch Filter needs to be configured also. That should the next goal.

1 Like