Loiter mode / arm problem

Hello, I previously disabled the battery arming voltage parameter by setting it to zero. Now I can arm with stabilize mode, but when I switch to loiter mode, it doesn’t arm. I know that the GPS lock must be active for the Loiter to work. That’s why I made arming check=1. Do you think the reason why the loiter doesn’t work is the change in the battery parameter? At the moment I am also getting an error for the gps value “bad gps position” maybe that’s why.

Well yea, that’s why…

1 Like

Thank you…I’ll go out and try

Hello again Dave. As you said, the problem is caused by GPS, so how do I solve it? Arms in stabilized and alt hold mode. In these modes, the GPS turns dark green when arming, but turns yellow immediately after switching to loiter mode. I didn’t enable geofencing. It also looks EKF vibe and 3D GPS. How can I handle it?

If it’s outside it will usually find enough Sat’s for a good position estimate eventually. What GPS module is it? Post your parameter file or a link to .bin Flight Log.